Unable to build app for testing - manifest ERROR

Got a LiveCode personal license? Are you a beginner, hobbyist or educator that's new to LiveCode? This forum is the place to go for help getting started. Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller

Tukcedo
Posts: 65
Joined: Fri Jun 27, 2014 9:43 pm

Re: Unable to build app for testing - manifest ERROR

Post by Tukcedo » Tue Jan 20, 2015 10:15 pm

Should it be 6.7.1 Richard? My 6.6.2 and 7.0.1 (I have those 2 "active") are building succesfully. No manifest errors.
Michel J.L. van der Kleij
Coding to help stray animals in the Philippines
Albert Foundation - http://albert.tukcedo.nl
Aklan Animal Rescue & Rehabilitation Center - http://aarrc.tukcedo.nl

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6969
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Unable to build app for testing - manifest ERROR

Post by FourthWorld » Tue Jan 20, 2015 10:56 pm

Thanks for the quick follow-up.

I've also tested in v7.0.1 with the same result, so it's encouraging that you're able to build for Android with that.

What versions of the JDK and Android SDK are you using? Are you using OpenJDK or Oracle's? 32-bit or 64?

And if you have time, it would be interested in learn if you also get success with LC 6.7.1, as that's the version I'm using most often right now.

I very much appreciate your assistance. If we can pin down the specific difference between my setup and yours causing my issue, I'll update the bug report so the team can correct for it.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6969
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Unable to build app for testing - manifest ERROR

Post by FourthWorld » Tue Jan 20, 2015 11:09 pm

Ignore my last post: I can now build successfully with v6.7.1 and 7.0.1. Not sure what changed and the last time this failed, but that seems to have resolved itself.

Now I have a different issue: when the app is run in the emulator, it launches, a black screen appears momentarily, and then it goes away.

Any clue on that?
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Tukcedo
Posts: 65
Joined: Fri Jun 27, 2014 9:43 pm

Re: Unable to build app for testing - manifest ERROR

Post by Tukcedo » Tue Jan 20, 2015 11:17 pm

I've got:

$ java -version
java version "1.8.0_05"
Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.5-b02, mixed mode)

Ubuntu 14.04: Linux ginger 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I must admit that I never use the emulator, despite 4Gb RAM in my laptop it's incredibly slow, so I attach the Android phone and do my testing there.
Michel J.L. van der Kleij
Coding to help stray animals in the Philippines
Albert Foundation - http://albert.tukcedo.nl
Aklan Animal Rescue & Rehabilitation Center - http://aarrc.tukcedo.nl

LCNeil
Livecode Staff Member
Livecode Staff Member
Posts: 1223
Joined: Wed Oct 03, 2012 4:07 pm

Re: Unable to build app for testing - manifest ERROR

Post by LCNeil » Tue Jan 20, 2015 11:43 pm

Hi Richard,

What version of the Android SDK do you have installed on your laptop as I have the most up to date SDK (R24)/Build tools and the error I believe this could be causing the error. You could try transferring the Android SDK from your workstation to your laptop to see if that fixes the build issue for now.

In regards to the black screen issue, I am sure this has been reported recently and its to do with using older AVDs (e.g. 2.2 and 2.3.3). The way to resolve this is to create a newer AVD (e.g 4.1.1) and deploy your app to that.

Kind Regards,

Neil Roger
--
LiveCode Support Team ~ http://www.livecode.com
--

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6969
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Unable to build app for testing - manifest ERROR

Post by FourthWorld » Wed Jan 21, 2015 12:18 am

Thanks again, Michel, but I'm pleased to report you can now ignore everything I've written. :)

I changed my emulator from Android 2.3.3 to 4.3.1, and while I don't know why the app refuses to start with the older image at least I can use the new one for testing.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6969
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Unable to build app for testing - manifest ERROR

Post by FourthWorld » Tue Jan 27, 2015 6:32 pm

Unfortunately I now have to say to ignore my last post - my earlier problems with the inexplicable "manifest error" remain on one machine.

On my Ubuntu 14.10 desktop everything works swell, but on my laptop running Ubuntu 14.04 - even with the same JDK, ADK, and LC versions - I only get the "manifest error".

Any clues as to how I might begin to diagnose this?
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Tribblehunter
Posts: 78
Joined: Wed Apr 10, 2013 9:08 pm

Re: Unable to build app for testing - manifest ERROR

Post by Tribblehunter » Fri Feb 13, 2015 12:18 am

Having similar issues, but as it is my first attempt at converting one of my programs from windows app to android it may be the programing.

Think i need a pointer to specific android functions which do not translate from windows....
Returning to try to learn livecode again.

But much greyer at the temples than the last time.

Simon
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 3901
Joined: Sat Mar 24, 2007 2:54 am
Location: Palo Alto

Re: Unable to build app for testing - manifest ERROR

Post by Simon » Fri Feb 13, 2015 5:02 am

Hi Tribblehunter,
This can happen when you change the settings on the standalone builder android tab.
The identifier cannot contain certain characters, I know "-" (hyphen) is definitely out but I think there are others, all letters are fine.
Also just found out today
Version code is a single character.

Both of those will throw a manifest error.

The best thing while starting out is to leave those as they came
com.yourcompany.yourapp and 1

Simon
I used to be a newbie but then I learned how to spell teh correctly and now I'm a noob!

Tribblehunter
Posts: 78
Joined: Wed Apr 10, 2013 9:08 pm

Re: Unable to build app for testing - manifest ERROR

Post by Tribblehunter » Fri Feb 13, 2015 7:10 am

Thanks for the input Simon. have double checked that. all ok.

It fails on assembling assets it appears. But I have no assets!! (assuming assets refer to images etc)

This is really stopping my progress. One reason for paying for the licence was because I needed multi platform capability!!

in addition, same happens when testing. App build fails at asset stage. Any pointers? I have android SDK no higher than 20 (as threads indicated may be problem with later versions)

am attempting with 'do not sign' and 'sign for development only'.. will try signing with key tonight just in case.
Returning to try to learn livecode again.

But much greyer at the temples than the last time.

LCNeil
Livecode Staff Member
Livecode Staff Member
Posts: 1223
Joined: Wed Oct 03, 2012 4:07 pm

Re: Unable to build app for testing - manifest ERROR

Post by LCNeil » Fri Feb 13, 2015 9:42 am

Hi Tribblehunter,

What version of LiveCode are you using? Are you still using 6.6.2 which is mentioned in your forum signature?

Kind Regards,

Neil Roger
--
LiveCode Support Team ~ http://www.livecode.com
-

Tribblehunter
Posts: 78
Joined: Wed Apr 10, 2013 9:08 pm

Re: Unable to build app for testing - manifest ERROR

Post by Tribblehunter » Sat Feb 14, 2015 1:10 am

updated info now.

windows desktop 8.1

livecode 6.7, 7.0, 7.0.1 and 7.0.2

Thanks for your assistance.
Returning to try to learn livecode again.

But much greyer at the temples than the last time.

ocascante
Posts: 1
Joined: Tue Feb 17, 2015 8:34 pm

Re: Unable to build app for testing - manifest ERROR

Post by ocascante » Tue Feb 17, 2015 8:41 pm

Hello,

I have ubuntu 14.04 64 bits, livecode 7.01, oracle jdk 8
I can configure android sdk path, but it is not possible to set jdk path. Always have "none" in livecode.

Somebody can help me?

Thanks.

Tribblehunter
Posts: 78
Joined: Wed Apr 10, 2013 9:08 pm

Re: Unable to build app for testing - manifest ERROR

Post by Tribblehunter » Sat Feb 21, 2015 9:13 pm

Still having problems with this.

Have built a simple app with Hello world, a couple of plain box graphics and a circle with gradient fill. I can build that but it does not work on test emulator, or when loaded to phone.

My other program (which works on windows) does not even build!

I have scoured the forums and checked that I have only up to version 20.

Can anyone help please???
Returning to try to learn livecode again.

But much greyer at the temples than the last time.

Tribblehunter
Posts: 78
Joined: Wed Apr 10, 2013 9:08 pm

Re: Unable to build app for testing - manifest ERROR

Post by Tribblehunter » Mon Mar 09, 2015 8:18 pm

rebuilt from scratch and now it works. Yay!
Returning to try to learn livecode again.

But much greyer at the temples than the last time.

Post Reply

Return to “Getting Started with LiveCode - Complete Beginners”