Unable to build app for testing - manifest ERROR

Got a LiveCode personal license? Are you a beginner, hobbyist or educator that's new to LiveCode? This forum is the place to go for help getting started. Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller

morrell
Posts: 84
Joined: Sat Dec 13, 2014 1:12 am
Location: United Kingdom

Re: Unable to build app for testing - manifest ERROR

Post by morrell » Tue Dec 23, 2014 2:42 am

Sorry I posted the above as it appears this subject presumed one knew all the setting up details such as 'Preferences/Mobile Support' which I had not done.

I'm now as far as 'Installing app on target device...' and will research further as to why I don't actually see my App.

Regards,

Ruth

Slattzo
Posts: 1
Joined: Wed Dec 24, 2014 7:40 am

Re: Unable to build app for testing - manifest ERROR

Post by Slattzo » Wed Dec 24, 2014 7:47 am

This error is plaguing me (and quite frankly is making me wanna quit LC)
"unable to generate package manifest...."
Ive tried *each* solution offered & still get it :(
Ive tried with emulator & real devices -- both mac & pc get this error.

Kennkil
Posts: 2
Joined: Mon Jan 05, 2015 10:31 pm

Re: Unable to build app for testing - manifest ERROR

Post by Kennkil » Wed Jan 07, 2015 7:43 am

I'm having the exact same "could not app for testing: unable to generate package manifest" error when attempting to test the device on both android simulator and on an android device. Changing the version number in standalone app settings didn't help either.

I've tried building the program on a mac (Yosemite) and PC (Windows 7). I'm using LiveCode Community version (LC7), Android studio 1.0.2, Java JDK version 7.

Any help or updates on this would be much appreciated!

LCNeil
Livecode Staff Member
Livecode Staff Member
Posts: 1223
Joined: Wed Oct 03, 2012 4:07 pm

Re: Unable to build app for testing - manifest ERROR

Post by LCNeil » Wed Jan 07, 2015 3:25 pm

Hi All,

Please make sure you are using the latest version of LiveCode (7.0.1) as there have been various Android SDK fixes implemented. The easiest place to download this version is from our main downloads repository here-

http://downloads.livecode.com/livecode

Kind Regards,

Neil Roger
--
LiveCode Support Team ~ http://www.livecode.com
--

Kennkil
Posts: 2
Joined: Mon Jan 05, 2015 10:31 pm

Re: Unable to build app for testing - manifest ERROR

Post by Kennkil » Wed Jan 07, 2015 6:42 pm

Thanks Neil for the quick reply. I was running version 7.0.0 and when I updated to 7.0.1 as you suggested and it worked. Thank you! I was able to test on the android device!

mrkco
Posts: 1
Joined: Tue Jan 13, 2015 3:12 pm

Re: Unable to build app for testing - manifest ERROR

Post by mrkco » Tue Jan 13, 2015 3:23 pm

Hi
I read older reply in this topic ..

so I have try these :

"LC 7.0.1 win stable"
SDK platform api 19
JDK 1.7 update 25
my AVD emulator api another is 19
Identifier is com.mrkco.hello
Signing is for developer only

im done
tnx
Last edited by mrkco on Wed Jan 14, 2015 2:23 pm, edited 3 times in total.

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6679
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Unable to build app for testing - manifest ERROR

Post by FourthWorld » Tue Jan 13, 2015 5:37 pm

Neil, I have to report that I'm stilling getting this on Ubuntu 14.04 using LC 7.0.1 and 6.7.1. My system is 64-bit - is there an undocumented requirement that I need to use the 32-bit Java build? What else might I be missing?

Also, FWIW, when the error dialog appears on Ubuntu it does so behind all other windows, which unfortunately happens with the confirmation dialog when a build is successful (see http://quality.runrev.com/show_bug.cgi?id=13888 ). Unless one is sufficiently familiar with LiveCode to be able to guess that's a window layering issue, to most folks it'll just appear as though the IDE is locked up, and they'll force-quit. But even for me, to have to move other windows out of the way to hunt down the error or confirmation dialog is a drag which I hope will be addressed soon.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

FxTradeX6
Posts: 27
Joined: Fri Dec 26, 2014 7:20 am

Re: Unable to build app for testing - manifest ERROR

Post by FxTradeX6 » Thu Jan 15, 2015 5:50 am

I'm starting to second guess my decision to spend $300 on an indy license and the create it course.. I up'd to 7.0.1 and get to "installing app on target device..." then nothing. After a few minutes the installing app message goes away and i get nothing on the emulator. There has to be a better way to make this stuff work.

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6679
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Unable to build app for testing - manifest ERROR

Post by FourthWorld » Thu Jan 15, 2015 5:53 am

FxTradeX6, which OS are you building on?
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

FxTradeX6
Posts: 27
Joined: Fri Dec 26, 2014 7:20 am

Re: Unable to build app for testing - manifest ERROR

Post by FxTradeX6 » Thu Jan 15, 2015 5:59 am

Windows 7, tried testing on 2.2 and 2.3.3 emulators.

LCNeil
Livecode Staff Member
Livecode Staff Member
Posts: 1223
Joined: Wed Oct 03, 2012 4:07 pm

Re: Unable to build app for testing - manifest ERROR

Post by LCNeil » Thu Jan 15, 2015 11:33 am

HI All,

@ ForthWorld- I will try setting up the latest SDK on my Ubuntu VM asap and let you know how I get on. I beleive I'm currently running 32bit JDK 1.7.0_65 on my VM

@ FXTradeX6- Try using a newer AVD (e.g. 4.1) as we've had some reports of older simulators not launching apps as expected.

Kind Regards,

Neil Roger
--
LiveCode Support Team ~ http://www.livecode.com
--

LCNeil
Livecode Staff Member
Livecode Staff Member
Posts: 1223
Joined: Wed Oct 03, 2012 4:07 pm

Re: Unable to build app for testing - manifest ERROR

Post by LCNeil » Tue Jan 20, 2015 1:57 pm

@ ForthWorld- It seems that this bug (or similar) is still present for LiveCode on Linux. I've set up the latest Android SDKS and use the following JDK version-

JAVA_VERSION="1.7.0_65"
OS_NAME="Linux"
OS_VERSION="2.6"
OS_ARCH="i586"

If possible, could you file a quick bug report with our QC team and we will investigate ASAP.

http://quality.runrev.com

Kind Regards,

Neil Roger
--
LiveCode Support Team ~ http://www.livecode.com
--

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6679
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Unable to build app for testing - manifest ERROR

Post by FourthWorld » Tue Jan 20, 2015 8:08 pm

Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Tukcedo
Posts: 65
Joined: Fri Jun 27, 2014 9:43 pm

Re: Unable to build app for testing - manifest ERROR

Post by Tukcedo » Tue Jan 20, 2015 9:25 pm

I'm a Linux-only user (Ubuntu 14.04) and I've tried LCC from 6.6.2 - 7.0.1 and although I've discovered a number of bugs, this one doesn't sound familiar. Can I test a stack to help out perhaps?
Michel J.L. van der Kleij
Coding to help stray animals in the Philippines
Albert Foundation - http://albert.tukcedo.nl
Aklan Animal Rescue & Rehabilitation Center - http://aarrc.tukcedo.nl

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6679
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Unable to build app for testing - manifest ERROR

Post by FourthWorld » Tue Jan 20, 2015 9:33 pm

Thanks for the assist, Michel. Feel free to run the simple recipe in the bug report I linked to above (basically, just to to build anything, even a simple one-card app, for Android).

If you have success please let me know so we can figure out the difference between your setup and mine. I'm also using Ubuntu 14.04 on my laptop (my workstation is 14.10), so at least we have that as a common starting point.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Post Reply

Return to “Getting Started with LiveCode - Complete Beginners”