Every project gets mouse set to hand :-(

Deploying to Linux? Get penguinated here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
Garrett
Posts: 386
Joined: Sat Apr 08, 2006 8:15 am
Contact:

Every project gets mouse set to hand :-(

Post by Garrett » Sun Aug 17, 2014 8:19 pm

Code: Select all

LiveCode 6.6.2
Linux Mint 17
Ubuntu based 14.04
GTK 2 & 3
Mate Desktop
Seems every project I create ends up with the cursor set to hand. I'm having to go in and set the cursor on mouseenter on everything here. Even if I set the cursor in openstack and preopenstack, everything still has the hand, except edit fields. I even went so far as to set the cursor on mouseenter on everything but the edit fields and no effect.

I have no special properties and nothing fancy going on. It's pretty straight and clean code that shouldn't affect the cursor. No html text, no links etc, just fields, labels, an option box, a combo box and push buttons. Not even any menus.

Anyone seen this behavior before and have any suggestions to cure it?

Thanks in advance,
~Garrett
'What you do not want done to yourself, do not do to others.' - Confucius (550 b.c. to 479 b.c.)

Garrett
Posts: 386
Joined: Sat Apr 08, 2006 8:15 am
Contact:

Re: Every project gets mouse set to hand :-(

Post by Garrett » Sun Aug 17, 2014 8:30 pm

Well now... all of a sudden after I post, after I spent near 30 minutes trying to figure this, now the cursor is arrow again.....

~Garrett
'What you do not want done to yourself, do not do to others.' - Confucius (550 b.c. to 479 b.c.)

Garrett
Posts: 386
Joined: Sat Apr 08, 2006 8:15 am
Contact:

Re: Every project gets mouse set to hand :-(

Post by Garrett » Mon Aug 18, 2014 5:47 pm

This is a slight annoyance. Seems that this randomly occurs where the cursor is changed to hand and stays that way for a while. This seems to only happen while working on the project in the IDE.

~Garrett
'What you do not want done to yourself, do not do to others.' - Confucius (550 b.c. to 479 b.c.)

Garrett
Posts: 386
Joined: Sat Apr 08, 2006 8:15 am
Contact:

Re: Every project gets mouse set to hand :-(

Post by Garrett » Sat Aug 23, 2014 8:35 pm

This problem still persists and it carries over to the standalone programs. Setting the cursor to arrow does nothing at all and I get different cursors all over the place, i beam, hand, the cursor for selecting objects and moving them, all of them except the arrow and regardless if I add code to the stack open, mouseenter, mouseleave card open and every object I have sets the cursor to arrow on mouseenter and mouseleave, but simply does nothing.

I do not have a Windows install and can't test on that end, nor OSX, but on Linux this is affecting any and every project I start and I have no clue how to resolve it and it is getting frustrating to the point of not wanting to use LiveCode. I also do not have another linux distro to test on to see if it's specific to this distro and version.

If anyone has any info or pointers regarding this it would be greatly appreciated. Thanks,
~Garrett
'What you do not want done to yourself, do not do to others.' - Confucius (550 b.c. to 479 b.c.)

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 7727
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Every project gets mouse set to hand :-(

Post by FourthWorld » Sat Aug 23, 2014 8:42 pm

Sounds like something somewhere is either setting the lockCursor or defaultCursor properties inappropriately.

Does your code do anything with cursors?
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Garrett
Posts: 386
Joined: Sat Apr 08, 2006 8:15 am
Contact:

Re: Every project gets mouse set to hand :-(

Post by Garrett » Sat Aug 23, 2014 9:06 pm

No. Only started messing with adding code to set the cursor to arrow because of the cursor issue. Is there anywhere I can check for that?

BTW, as a side note, I broke out my old Rev 2.6.1 and tried that. No cursor issue there... Not that this would be helpful, but just had to do it for my own sanity.

~Garrett
'What you do not want done to yourself, do not do to others.' - Confucius (550 b.c. to 479 b.c.)

Garrett
Posts: 386
Joined: Sat Apr 08, 2006 8:15 am
Contact:

Re: Every project gets mouse set to hand :-(

Post by Garrett » Sat Aug 23, 2014 9:55 pm

I should also note that this is on a recent clean OS install and LiveCode. The install was from the download and not the .deb provided by another user.

~Garrett
'What you do not want done to yourself, do not do to others.' - Confucius (550 b.c. to 479 b.c.)

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 7727
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Every project gets mouse set to hand :-(

Post by FourthWorld » Sun Aug 24, 2014 12:11 am

I use 6.6.2 on Ubuntu myself pretty much daily, but I haven't yet seen this issue (except in cases where my own cursor handling gets in the way <g>).

If you find a repeatable recipe please post it, and consider filing a bug report on it:
http://quality.runrev.com/
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Garrett
Posts: 386
Joined: Sat Apr 08, 2006 8:15 am
Contact:

Re: Every project gets mouse set to hand :-(

Post by Garrett » Sun Aug 24, 2014 8:23 pm

Appreciate the help and replies but decided to drop Linux and go back to Windows. I was finding that issues like this were cropping up too much for me not only with LiveCode but with another programming language. Also couldn't find a distro to properly handle dual monitors without some sort of quirk.

~Garrett
'What you do not want done to yourself, do not do to others.' - Confucius (550 b.c. to 479 b.c.)

Post Reply

Return to “Linux”