Livecode keeps deleting my widget files!!!!!

Moderators: LCMark, LCfraser

Post Reply
pink
Posts: 224
Joined: Wed Mar 12, 2014 6:18 pm

Livecode keeps deleting my widget files!!!!!

Post by pink » Fri Aug 17, 2018 2:09 pm

Here's the sequence...

I open the lcb file in Extension Builder

I click "Test"... everything works fine
I click "Package"... lce file successfully built (confirmed by looking in the directory)
I click "Stop Testing".... so far so good, everything is still there
I click "Install"...the following happens:

1. Everything in my widget's folder is deleted including the lce, the lcb, and the support folder
2. I get an error message saying "extension missing from {FILEPATH}"

If I didn't have the lcb file still open in Atom, I would've lost everything.

I have tried this numerous times (with copies obviously) and it keeps happening around 80% of the time

I've tested this on different machines, with both the Community and Indy versions to see if there were any differences.
Greg (pink) Miller

MadPink, LLC
I'm Mad, Pink and Dangerous to Know

bwmilby
Posts: 198
Joined: Wed Jun 07, 2017 5:37 am
Location: New Orleans, LA
Contact:

Re: Livecode keeps deleting my widget files!!!!!

Post by bwmilby » Sat Aug 18, 2018 12:17 am

Are you editing inside the My LiveCode folder?
Brian Milby

Script Tracker https://github.com/bwmilby/lc-misc/tree/master/ScriptTracker

pink
Posts: 224
Joined: Wed Mar 12, 2014 6:18 pm

Re: Livecode keeps deleting my widget files!!!!!

Post by pink » Sat Aug 18, 2018 1:13 pm

yes I am... I have a Documents folder in My LiveCode in which I keep my stacks and the extensions I am building
Greg (pink) Miller

MadPink, LLC
I'm Mad, Pink and Dangerous to Know

bwmilby
Posts: 198
Joined: Wed Jun 07, 2017 5:37 am
Location: New Orleans, LA
Contact:

Re: Livecode keeps deleting my widget files!!!!!

Post by bwmilby » Sat Aug 18, 2018 4:35 pm

Which OS are you using? I just tried several different locations on my Mac (Sierra) and could not duplicate the behavior. I even tried changing the order (start testing/stop testing/install also worked fine - LCE was built at that point automatically). The only requirement is that you stop testing before you install. This is the full path that I used for the test:

Code: Select all

/Users/milby/Documents/My LiveCode/Documents/Extensions/Primes/primes.lcb
Which installed to:

Code: Select all

/Users/milby/Documents/My LiveCode/Extensions/us.milby.library.primes.0.0.1
This is the file that I'm testing with:
primes.lcb.zip
(1009 Bytes) Downloaded 8 times
Brian Milby

Script Tracker https://github.com/bwmilby/lc-misc/tree/master/ScriptTracker

pink
Posts: 224
Joined: Wed Mar 12, 2014 6:18 pm

Re: Livecode keeps deleting my widget files!!!!!

Post by pink » Sat Aug 18, 2018 6:35 pm

using your library, it didn't happen... actually, I don't think it is happening with libraries, only widgets
Greg (pink) Miller

MadPink, LLC
I'm Mad, Pink and Dangerous to Know

bwmilby
Posts: 198
Joined: Wed Jun 07, 2017 5:37 am
Location: New Orleans, LA
Contact:

Re: Livecode keeps deleting my widget files!!!!!

Post by bwmilby » Sat Aug 18, 2018 6:59 pm

Ok. I’ll pull up a widget and do another test.
Brian Milby

Script Tracker https://github.com/bwmilby/lc-misc/tree/master/ScriptTracker

Post Reply

Return to “LiveCode Builder”