Deployment to WEB

Anything beyond the basics in using the LiveCode language. Share your handlers, functions and magic here.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

SteveHanlan
Posts: 80
Joined: Fri Jul 09, 2010 6:28 pm

Deployment to WEB

Post by SteveHanlan » Wed May 11, 2011 7:53 pm

I am having trouble deploying to the web, just running the test.html (this and the revlet file are both on the website

I have installed RevWeb, and I get nothing in FireFox4 and an error (There was an error loading the revlet - could not open input file) in IE.
In Safari on the iPad it offered the download of RevWeb, but it would not install, ("Cannot modify header information .......")

Not sure what I am missing, any help would be appreciated.

Also, once this is solved, how do other users run my web app?

Cheers

Steve

BvG
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 1236
Joined: Sat Apr 08, 2006 1:10 pm
Location: Zurich
Contact:

Re: Deployment to WEB

Post by BvG » Wed May 11, 2011 9:24 pm

You can try to run the test locally. Just double click on the test.html file in your finder/explorer. Every user will need to install the web plugin for their browser to run your web content, and it is currently available for mac and windows, but not linux or mobile browsers (those normally do not allow plugins).
Various teststacks and stuff:
http://bjoernke.com

Chat with other RunRev developers:
chat.freenode.net:6666 #livecode

SteveHanlan
Posts: 80
Joined: Fri Jul 09, 2010 6:28 pm

Re: Deployment to WEB

Post by SteveHanlan » Wed May 11, 2011 10:53 pm

Local test is fine, but browsers seem to be blocking the revlet.

Steve

doc
Posts: 148
Joined: Fri Jun 09, 2006 4:30 pm
Location: Oklahoma, USA

Re: Deployment to WEB

Post by doc » Thu May 12, 2011 3:29 am

Hello Steve,
It seems that Firefox 4.0 series have problems with the plugin (no fault of LC) because the 3.X series worked just fine. I have exactly the same problem here on my end. If you are running Windows, I.E. 9 doesn't work either in 64Bit mode, but the 32Bit version seems to be okay.

RevWeb is basically non-functional until the LC team resolves the issues with the latest browser and CPU combo's.

Best regards,
-Doc-

mhoneywill
Posts: 66
Joined: Fri Feb 05, 2010 7:31 pm

Re: Deployment to WEB

Post by mhoneywill » Thu May 12, 2011 12:18 pm

It Also does not work with Chrome.

I agree the team at RenRev need to look at this as it limits the use of RevWeb

Regards

Martin

Dixie
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 1336
Joined: Sun Jul 12, 2009 10:53 am
Location: Bordeaux, France

Re: Deployment to WEB

Post by Dixie » Thu May 12, 2011 12:45 pm

Steve...

I am not having too many problems using the revWeb plugin... I have just checked one of my revlets with a number of browsers... the revlet can be found at http://gemetest.ihouse.on-rev.com and the browsers that I ran it with are as follows :-

Firefox 4.0.1, OmniWeb 5.10.3, Opera 11.10, Safari 5.05....

It does not seem to want to run under Chrome, it starts to load but does not quite get there... I don't consider 4 out of 5 to be too bad at all.

be well

Dixie

doc
Posts: 148
Joined: Fri Jun 09, 2006 4:30 pm
Location: Oklahoma, USA

Re: Deployment to WEB

Post by doc » Thu May 12, 2011 1:23 pm

Hello Dixie,
Out of curiosity, what system and OS specs are you using?

Best regards,
-Doc-

Dixie
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 1336
Joined: Sun Jul 12, 2009 10:53 am
Location: Bordeaux, France

Re: Deployment to WEB

Post by Dixie » Thu May 12, 2011 1:32 pm

Hi Doc...

The revlet was made with runRev 4.0... I am running MacOSX 10.6.7.

take care

Dixie

doc
Posts: 148
Joined: Fri Jun 09, 2006 4:30 pm
Location: Oklahoma, USA

Re: Deployment to WEB

Post by doc » Thu May 12, 2011 4:29 pm

From my end, it kinda looks and works like this with Firefox 4.0.1 on my 64 bit Win 7 box:

Image

Doesn't currently work in Safari, Chrome (never has) nor in IE9 64bit... and of course, the Linux plugin has been M.I.A. the whole way. It's an awesome idea and I have several project ideas in mind for when it becomes functional for everyone without concern for platform, cpu or o/s.

Does seem to work with the 32 bit version of IE9 on the same Windows box....
Does work on my Mac Mini running Safari 5.05 and Firefox 3.6.17

Very nice work, btw! :)

Best regards,
-Doc-

acidjazz
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 93
Joined: Mon Feb 16, 2009 2:37 am
Location: Tampa, FL

Re: Deployment to WEB

Post by acidjazz » Mon Jun 06, 2011 7:34 pm

I too can confirm that your (very cool looking) revlet (should it be called a "Livelet" now?) does not work on Firefox 4.0 or 4.01.

As for Google Chrome, according to an article in CNET this week, 1 in 8 people use Chrome, and more use it than Safari. Indeed, the graph shows that Chrome has grown the most, worldwide, since 2009. So, it's absolutely maddening that the good folks at runrev can't seem to get the plugin to work.

Mark

Image

Dixie
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 1336
Joined: Sun Jul 12, 2009 10:53 am
Location: Bordeaux, France

Re: Deployment to WEB

Post by Dixie » Mon Jun 06, 2011 8:09 pm

Mark...

The revLet ('liveLet') does run under MacOSX 10.6.7 with the following ...Firefox 4.0.1, OmniWeb 5.10.3, Opera 11.10, Safari 5.05.... I do agree with you however that it does not want to run using a partition with bootcamp under WindowsXP using Firefox... it loads, but does not function... It used to run but that must have been using FireFox 3.x.x....

I am sure that getting the plugin to work is one of runRev's priorities, but I guess thay have their hands full with mobile stuff at the moment... patience is a word that springs to mind...

be well

Dixie

acidjazz
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 93
Joined: Mon Feb 16, 2009 2:37 am
Location: Tampa, FL

Re: Deployment to WEB

Post by acidjazz » Mon Jun 06, 2011 9:45 pm

Dixie,

I forgot to mention that the particular computer I'm on is a Windows machine using XP. Sorry for the confusion!

As for patience,... I only post my "when is chrome-ready plug-in coming?" about once every 6 months. This is the *third* time I've posted. I'd say waiting 1.5 years for something is at least moderately patient. :)

Best,
Mark

admin12
Posts: 412
Joined: Wed May 11, 2011 9:47 am

Re: Deployment to WEB

Post by admin12 » Sun Jul 10, 2011 12:10 am

Try the following code. I found that it is the HTML that is causing some of the problems in some of the browsers. This makes it work in everything but Chrome for me.

<html>
<head>
</head>

<body>

<center>

<object classid="CLSID:B2EC94AF-4716-4300-824A-3314BF23664A" width=1228 height=608>
<param name="src" value="CampStaffUSAReports.revlet"/>
<param name="stack" value="CampStaffUSA Reports"/>
<param name="requestedName" value=""/>
<param name="instanceID" value=""/>
<embed type="application/x-revolution"
src="CampStaffUSAReports.revlet"
width=1228 height=608
stack="CampStaffUSA Reports"
requestedName=""
instanceID=""
></embed>
</object>

<script type="text/javascript">
var agt=navigator.userAgent.toLowerCase();
var ie = (agt.indexOf("msie") != -1);
var ns = (navigator.appName.indexOf("Netscape") != -1);
var win = ((agt.indexOf("win")!=-1) || (agt.indexOf("32bit")!=-1));
var mac = (agt.indexOf("mac")!=-1);
if(ie && win){ pluginlist = detectIE("RunRev.RevWebPluginCtrl.1","Revolution"); }
if (ns || !win){ nse = ""; for(var i=0;i<navigator.mimeTypes.length;i++) nse += navigator.mimeTypes.type.toLowerCase(); pluginlist = detectNS("application/x-revolution","Revolution"); }
function detectIE(ClassID,name) { result = false; document.write('<SCRIPT LANGUAGE=VBScript>\n on error resume next \n result = IsObject(CreateObject("' + ClassID + '"))\</SCRIPT\>\n'); if (result) return name+','; else return ''; }
function detectNS(ClassID,name) { n = ""; if (nse.indexOf(ClassID) != -1) if (navigator.mimeTypes[ClassID].enabledPlugin != null) n = name+","; return n; }
pluginlist += navigator.javaEnabled() ? "Java," : "";
if (pluginlist.length > 0) pluginlist = pluginlist.substring(0,pluginlist.length-1);
var plugin = document.getElementById("plugin");
var noplugin = document.getElementById("noplugin");
plugin.style.display = "none";
noplugin.style.display = "none";
if(pluginlist.indexOf("Revolution")!=-1){ plugin.style.display = "block"; }else{ noplugin.style.display = "block"; }
</script>

</center>

</body>
</html>

Mike

justintime
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 8
Joined: Fri Jul 15, 2011 1:27 am

Re: Deployment to WEB

Post by justintime » Fri Jul 15, 2011 1:34 am

Another interesting point... why so much focus on mobile deployment apps? Get the plugins to work in a mobile web environment. I just wish the darn thing worked in common web environments reliably. Its not like this is a free development platform. Paying customers have a right to demand the functionality that was promised when purchased.

admin12
Posts: 412
Joined: Wed May 11, 2011 9:47 am

Re: Deployment to WEB

Post by admin12 » Sat Jul 23, 2011 6:24 pm

It seems that when new versions of some browsers came out, it broke the LiveCode html code (specifically where it tries to see if you have the LiveCode revlet player installed or not. By removing that, it works, except on chrome).

Runrev needs to fix that.

Mike

Post Reply

Return to “Talking LiveCode”