Page 1 of 1

Semi Corrupt Stack

Posted: Wed Jan 16, 2019 7:16 pm
by thehat
Apparently, while trying to rename a stack I used a name that was taken. At this point, LiveCode would not let me do anything. Eventually, I needed to force quit. The Stack reopened and functioned properly. When I tried to fix the problem substack, no Luck.

No part of this stack shows up in the project browser.

I put all substacks in a field and set the field to open the substacks. All open except the problem substack. The problem substack is listed in the field but will not open.

After I use the stack it appears to continue functioning properly and saves any changes,

I can close all windows except the Home window in the normal “quit and save script”. That script originally closed all windows in the stack. Now it saves and closes all but the home stack. That window will close only if I close it from the LiveCode Menu or the message box. At this point, I cannot quit LiveCode from the menu or the message box. I need to go to the Apple Menu to “Force Quit”.

The stack was written and is being run in 7.1.3. If I run a copy in 9.0 I get the same results.

I hope this make some sense.

Thanks for any ideas.

Re: Semi Corrupt Stack

Posted: Wed Jan 16, 2019 7:27 pm
by bogs
While what you said makes sense to me, I've never been able to pull a stack back from that particular problem :?

Hopefully someone that has had more success doing so will chime in soon.

Re: Semi Corrupt Stack

Posted: Wed Jan 16, 2019 8:54 pm
by FourthWorld
Good to see you here, even if for something annoying. Call me and we can walk through some diagnostics.

Re: Semi Corrupt Stack

Posted: Fri Jan 18, 2019 4:29 pm
by thehat
Thank you, Richard. :D Will do.