Search for required inclusions- not working

Anything beyond the basics in using the LiveCode language. Share your handlers, functions and magic here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
tetsuo29
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 63
Joined: Thu Jun 07, 2007 1:30 am

Search for required inclusions- not working

Post by tetsuo29 » Sat Nov 29, 2014 8:41 pm

Hi. I'm starting a new thread because I think I've determined that the real problem I'm having is that in the Standalone Application Settings dialog, "Search for required inclusions when saving the standalone application" no longer works and using the "Select inclusions for the standalone application" is kind of like voodoo as a work around- sometimes it includes revCommon and sometimes it doesn't. On my OS X Yosemite running LC 7.01 rc2, I had to highlight Font Support in order for revCommon to get included in my standalone- and even then it only included it in the Mac & Windows standalones. On Linux (Elementary OS 0.2 "Luna") running LC 7, when I first ran the standalone built from my Mac revCommon apparently wasn't included and I had to highlight another seemingly unrelated Script Library and rebuild in order to get revCommon support in my standalone.

Why do I think revCommon isn't being included? Because I read in another forum thread that this is why certain methods like recMacFromUnixPath or revChangeWindowSize end up not working in standalone builds when they work in the IDE just fine.

So, my question really is, is there any way to scrub/reset the build settings in my stack and get "Search for required inclusions" working again? I've never even bothered with "Select inclusions" before? Oh, and is this a bug that needs to be reported?

As always, any help is greatly appreciated.

Thanks.

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 8280
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Search for required inclusions- not working

Post by FourthWorld » Sat Nov 29, 2014 9:29 pm

I believe revCommon is always included in a standalone; indeed, I've found no way to have it not included.

What may be happening is that something in your app's initialization sequence is affecting the way the included Rev libs get initialized.

Does your app's mainstack have a startup handler, or a preOpenBackground handler? What does its initialization sequence look like?
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

FireWorx
Posts: 362
Joined: Wed Sep 07, 2011 9:39 pm

Re: Search for required inclusions- not working

Post by FireWorx » Mon Dec 01, 2014 6:40 am

I think you may be on to something. I have a LC stack that downloads zipped folders containing PDF's from a web server and I use the libUrlDownloadToFile to do that. LC 6.6.4 and LC 6.7 do that just fine in the IOS simulator but with absolutely no changes to the file LC 7.0 doesn't download the files at all.

Although these issues could be linked it is the Internet library that doesn't seem to be loading in the Inclusions section and it could be IOS related. My stacks are filled with IOS specific code and have only been tested on the IOS simulator and I feel it should be looked at by the LC IOS community. I have provided a 6.6.4 stack and a 7.0 stack to show that the 7.0 stack fails. In order to run on the desktop rather than the IOS simulator the code will have to be altered. Here is the link.

http://forums.livecode.com/viewtopic.php?f=49&t=22241

Thanks
Dave

Post Reply

Return to “Talking LiveCode”