Page 1 of 1

Uninstalling Rev Studio Demo

Posted: Thu Jul 13, 2006 2:54 pm
by pelkofg053
I just purchased a license for Rev Studio for the Windows platform; however, the expired demo copy (ver 2.7.1) remains on my computer.

With many software packages it's usually best to remove older versions and/or demo software prior to installing a newer full version. Thus, I attempted to uninstall the demo version of Revolution.

The uninstall program ran, and reported back that all versions of Revolution had been been removed. Upon further inspection, however, the uninstaller removed absolutely nothing - no icons, no start menus, no directories, no executables, no .dll's, no documentation.

I've run the uninstaller twice, with the same lack of results.

Anybody else run into this?

Just for the record, and future updates, is it necessary to remove prior versions before upgrading to a newer version?

Judging from the directory structure under the "Revolution Studio" directory, I'm guessing that older versions are kept on the machine, and are not overwritten by newer versions.



Posted: Thu Jul 13, 2006 8:25 pm
by Garrett
Did you reboot? I know some installers require a reboot before they
actually kick the uninstall actions in.


Posted: Thu Jul 13, 2006 8:46 pm
by pelkofg053

Yup. Rebooted with no effect.

I'm wondering if this is related to the problem I had during the installation of the demo.

The icons that were created by the installer did not reference the correct directory (i.e., "C:\Program Files\Revolution Studio\2.7.0-gm-1\", rather than "C:\Program Files\Revolution Studio\2.7.1-gm-1\", where the executables/dll's were actually stored).

The problem was easily fixed by changing the 2.7.0 to 2.7.1 in the icon properties.

That said, I'm wondering if the uninstall utility is attempting to remove version 2.7.0, which is not actually on the machine.



Posted: Fri Jul 14, 2006 8:13 pm
by Garrett
That's possible.

I can't honestly say though since I've never tried the demo on Windows
at all. Only Linux and Mac.


Posted: Mon Jul 17, 2006 8:24 pm
by Mark
Hi George,

AFAIK, the Rev installer for Windows still doesn't work properly. If you want to remove something, you have to do it manually. If you want shortcuts to point to the right application, you have to change them manually as well.



Posted: Tue Jul 18, 2006 1:25 am
by pelkofg053

Just out of curiosity, how long has the installer/uninstaller been broken? It appears that version 2.6 used InstallShield, but 2.7 uses something else. Is the 2.7 installer written in Revolution?

As a trial user (and now a paid new user), the failure of any application to properly install over such a small matter as incorrect directory paths in an icon (small to me, but possibly not to other potential new purchasers) is unbelievable. It does not make a good first impression to a new user when a freshly loaded demo/application won't start from the desktop.

Applications that don't completely uninstall (i.e., data, executables, dll's, directories, and/or registry entries left behind) have always been a pet peeve of mine. I have to say that this one takes the cake, since it apparently removes absolutely nothing, and even worse, reports that it has.

That said, I will continue to forge ahead with Revolution. Hopefully, I won't ever want to remove it from my system <grin>...