Page 1 of 2

Field hilited text color on Windows

Posted: Thu Jul 26, 2018 5:42 pm
by trevix
On OSX10.12.6 and Windows 7 (LC 8.1.10) I have a stack with a field, in thee IDE set in the property palette to Auto hilite and List behaviour.
On OSX I set the text color to black and the hilite fill to 118,228,255 (azure)
Clicking on a line, it correctly select it, the text stay black and the background of the selected line is azure. Good

Now opening the same stack on Windows, I notice:
- the text fill is black (OK)
- the Hilite fill is now 0,0,255 (dark blue) ?
- when a line gets selected, the text become white and the line background is dark blu (very hard to read).
Why?

The same using other colours, on line selection:
OSX: the text is black and the Hilite fill= 255,177,145 (orange)
Windows: the text become white and the Hilite fill become: 255,0,0 (full red)
Is there a way to fix this (trying to make the same user experience on both platform). Am I missing something?

Thanks
Trevix

Re: Field hilited line color differs from OSX to Windows

Posted: Thu Jul 26, 2018 6:58 pm
by FourthWorld
I'm unable to reproduce that. Here, in the rare case where I need to use highlight treatments other the the ones user's expect on their platform of choice, assigning the colors I want on one OS carries through to the others.

What happens when you try it the other way around, setting the colors on Windows, saving, and then opening on a Mac?

Re: Field hilited line color differs from OSX to Windows

Posted: Thu Jul 26, 2018 8:11 pm
by trevix
My problem is that on Windows the halite text become white, no matter what.

Funny: going the other way around the hilite color stay the same on both platform.
Getting the same stack back to Windows, the hilite color are reversed to blue and red (from azure and orange).

I could correct things in scripts on Windows but the problem is that the hilite text color in Windows is alway white, so as to make unavoidable a dark hilite background. Reassigning on the property palette a black color, does not change the text that stay white (when hilite).

The Windows monitor is set to millions of colours so I don't think it depends from running on VMware.

Re: Field hilited line color differs from OSX to Windows

Posted: Thu Jul 26, 2018 9:39 pm
by richmond62
I suspect this is a system-wide setting . . .

THIS is "a pain" as it seems that we mortal cannot change this:
-
Screen Shot 2018-07-26 at 11.36.15 pm.png
Screen Shot 2018-07-26 at 11.36.15 pm.png (24.12 KiB) Viewed 1614 times
-
as THIS (pseudocode) would be lovely:

set the selectedColor of fld "xxx" to "red"[/b]
-
However, you can set the selectedColor via the Properties Palette, and this SHOULD
guarantee that cross-platform.

Re: Field hilited line color differs from OSX to Windows

Posted: Fri Jul 27, 2018 1:43 pm
by trevix
Unfortunately not.
on Windows, changing the selected color with the palette does not modify the selected text that stay white.

Re: Field hilited line color differs from OSX to Windows

Posted: Fri Jul 27, 2018 6:03 pm
by jacque
I remember this from ages ago. The OS sets the color and I believe it depends on the saturation of the background color the text is against. You came close with the blue / red vs. azure
/ orange. I think the difference there is due to the different color palettes Windows and Mac use. You might have better luck if the background color is lighter.

Re: Field hilited line color differs from OSX to Windows

Posted: Fri Jul 27, 2018 6:08 pm
by jacque
trevix wrote:
Fri Jul 27, 2018 1:43 pm
Unfortunately not.
on Windows, changing the selected color with the palette does not modify the selected text that stay white.
The hilitedcolor refers to the color of the line fill, but does not affect the color of the text in the line. Windows seems to really like white text if the background is even marginally dark.

@Richmond, a reserved word doesn't necessarily mean that it is being used internally by the engine, but rather that it may be in the future so you shouldn't use it in your own scripts now.

Re: Field hilited line color differs from OSX to Windows

Posted: Sat Jul 28, 2018 10:05 am
by trevix
If I may, with a very light yellow hilite color, the selected text stay white on Windows.
You even get white text on white hilite color: this can't be right.
TestHilite.PNG

Re: Field hilited line color differs from OSX to Windows

Posted: Sat Jul 28, 2018 5:20 pm
by jacque
I'd call that a bug and report it to the bug database. What happens if you reset the hilite color to the default?

Re: Field hilited line color differs from OSX to Windows

Posted: Sat Jul 28, 2018 6:48 pm
by richmond62
Just to be bloody-minded I have knocked together a fairly goofy stack over here on the wild side (Mac OS 10.7.5) with LC 8.1.10, and I am currently installing the Windows Community LC 8.1.10 install under WINE on the same MacOS system.

Wow: doing this takes ages.

Here's what the stack looks like on Macintosh:
-
HighAsAKite.png
-
HighAsAKite2.png
- and here's the stack:
-
HIGH LIGHTER.livecode.zip
(7.02 KiB) Downloaded 34 times

Re: Field hilited line color differs from OSX to Windows

Posted: Sat Jul 28, 2018 7:11 pm
by richmond62
Blast: I couldn't get LiveCode 8.1.10 for Windows to behave with WINE bottler . . . so off I go to Linux.

I have had no problems recently running Windows builds of LiveCode with WINE on Linux.

Mind you, that was on a machine that had most of its ports blown to blazes in
a thunderstorm just before I went to the States.
-
mental.jpg
-
Macintosh on the left, Xubuntu on the right. 8)
-
Hmm: Windows 10 in VirtualBox . . .
-
Oh, well, while we're waiting:
-
mental2.jpg
-
The G5 iMac PPC isn't needed right now . . . but very useful for HC stacks, and so on.
-
mental3.jpg
-
Yup: mustn't get distracted.

Even if those photos are a demonstration how one can keep one's head above water for about $500. 8)

Re: Field hilited line color differs from OSX to Windows

Posted: Sat Jul 28, 2018 9:02 pm
by FourthWorld
AFAIK the LC Windows engine has always used the field's backgroundColor as the color of highlighted text. This works well if you use the defaults and want to provide a standard appearance, but is indeed problematic if you need a custom look and are using a light highlight color and light background.

I believe you'll need to submit an enhancement request for that:
https://quality.livecode.com

Re: Field hilited line color differs from OSX to Windows

Posted: Sat Jul 28, 2018 9:57 pm
by richmond62
What an awful, long wait that was . . .
-
HighAsAKite3.png
-
HighAsAKite4.png
-
Well; the ONLY thing I'd get excited about was the way the high-lighted text turns white.

The hiliteColor seems the same on Windows 10 as on Mac OS 10.7.5

Re: Field hilited line color differs from OSX to Windows

Posted: Sun Jul 29, 2018 9:48 am
by richmond62
My test seemed to behave exactly opposite to trevix's one.

Re: Field hilited line color differs from OSX to Windows

Posted: Sun Jul 29, 2018 11:48 am
by trevix
I cannot anymore reproduce the hilited line color change between OSX and Windows on a new simple stack, so I may have messed up in my standalone defaults. Sorry.

My problem then is the hilited text color:

A) Resetting the hilite fill turns it to dark azure, always with white text.

B) & C) as FourthWorld mentioned, LC Windows engine seems to always use the field background color as the color of highlighted text.

D) in my case, and I suspect this is pretty common, I want to keep the field backroundcolor white, have a light hilite line color (as not to mess up with the aesthetic of the stack) and I see no way to force the selected text color to any color or to stay black as is, in order to make it readable. Note that no other change in the palette can change this.
Is there another way?
Thanks
Hilite2.PNG