Incorrect "Column does not exist" error from dataGrid

LiveCode is the premier environment for creating multi-platform solutions for all major operating systems - Windows, Mac OS X, Linux, the Web, Server environments and Mobile platforms. Brand new to LiveCode? Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
dpatterson
Posts: 24
Joined: Wed Jan 18, 2017 5:38 pm

Incorrect "Column does not exist" error from dataGrid

Post by dpatterson » Tue Jun 13, 2017 7:11 pm

I added a new dataGrid to a card, named it, and added my columns to it.
When I try to set the alignment of the headers with

Code: Select all

set the dgHeaderAlignment["id"] of group "vendorsGrid" of card "lists" to "left"
LC reports the following error:

Code: Select all

Message execution error:
Error description: Object: object does not have this property
Hint: column 'id' does not exist
The column "id" most certainly does exist.
See the uploaded screen shot.
Screen Shot 2017-06-13 at 11.08.59 AM.png
Screen shot showing the column definition
I've tried quitting and restarting; no joy.
I deleted the dataGrid, created a new one, and added a single column named "id". Same results
I haven't set any custom behaviors, yet, so it isn't that.

I'm running LiveCode V9.0.0 DP 6.

Color me very confused.
Thanks in advance.

dpatterson
Posts: 24
Joined: Wed Jan 18, 2017 5:38 pm

Re: Incorrect "Column does not exist" error from dataGrid

Post by dpatterson » Tue Jun 13, 2017 9:53 pm

After much pulling of hair, I finally figured it out.
There was a mysterious numbered group in the card and it contained another group named "vendorsGrid".
I have no idea where either of them came from.
I had to delete it using the message box. The Project Browser wouldn't.

Strange.

Post Reply

Return to “Getting Started with LiveCode - Experienced Developers”