Screen Flash and Visual Effect

LiveCode is the premier environment for creating multi-platform solutions for all major operating systems - Windows, Mac OS X, Linux, the Web, Server environments and Mobile platforms. Brand new to LiveCode? Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

[-hh]
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2035
Joined: Thu Feb 28, 2013 11:52 pm
Location: Göttingen, DE

Re: Screen Flash and Visual Effect

Post by [-hh] » Sun Nov 16, 2014 4:11 pm

Hi,

one thing you could test is to increase the syncrate (I would start with 25), because especially laptops have very different screen update cycles, influenced by the energy saver.

I had in a loop of 100 repeats with your demo stack no single screen flash on a Mac Desktop (OS 10.10) and LC 5.5.5, 6.6.5, 6.7.1. 7.0.1

So this could be a problem of your MacBook rather than of LC. Did you try with a power supply and energy saver off?
Perhaps your MacBook has also a problem with the fact that your pictures have different sizes (different heights) and the card background is white?
shiftLock happens

RogGuay
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 61
Joined: Fri Apr 28, 2006 12:10 am

Re: Screen Flash and Visual Effect

Post by RogGuay » Mon Nov 17, 2014 2:33 pm

Thanks for the great ideas, most of which I had not thought of. Unfortunately none of them make a difference! Still get the flashing. BTW, I may not have been clear about this but, this problem started only after upgrading to Yosemite. I've used this "unlock screen with visual effect ..." for years w/o problems prior to Yosemite . . . same machine, same stacks etc.

Thanks again for looking at this.
[-hh] wrote:Hi,

one thing you could test is to increase the syncrate (I would start with 25), because especially laptops have very different screen update cycles, influenced by the energy saver.

I had in a loop of 100 repeats with your demo stack no single screen flash on a Mac Desktop (OS 10.10) and LC 5.5.5, 6.6.5, 6.7.1. 7.0.1

So this could be a problem of your MacBook rather than of LC. Did you try with a power supply and energy saver off?
Perhaps your MacBook has also a problem with the fact that your pictures have different sizes (different heights) and the card background is white?

Ken3D
Posts: 16
Joined: Sun Mar 02, 2014 12:54 am

Re: Screen Flash and Visual Effect

Post by Ken3D » Mon Dec 15, 2014 7:48 pm

Any news on this? I see that with 6.7.1 (rc 4) it's still flashing.

RogGuay
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 61
Joined: Fri Apr 28, 2006 12:10 am

Re: Screen Flash and Visual Effect - Solved?

Post by RogGuay » Fri Jan 09, 2015 8:04 pm

Some time ago, I reported a problem with random screen flashes that came about with the release of Yosemite and all recent releases of LC. I think I may have discovered the cause.

The problem seems to be exacerbated by having plugin stacks open. My setup was to have 2 of my favorite plugins automatically open when LC is launched. I recently discovered that the random screen flashes are at least far less frequent if I close these plugins. Does this make sense . . . especially since it seems to be Yosemite specific?

Thanks,
Roger

RogGuay
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 61
Joined: Fri Apr 28, 2006 12:10 am

Re: Screen Flash and Visual Effect

Post by RogGuay » Fri Jan 09, 2015 8:23 pm

I spoke too soon. It just came back with a vengeance!! Open plugin stacks are definitely NOT the cause of my screen flash problem.

Roger

Ken3D
Posts: 16
Joined: Sun Mar 02, 2014 12:54 am

Re: Screen Flash and Visual Effect

Post by Ken3D » Sun Aug 16, 2015 6:15 pm

This is still happening. About 20% of the time when using a visual effect it flashes. Is this getting any attention? Does it need to be logged as a bug in order to get attention?

Thanks.

RogGuay
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 61
Joined: Fri Apr 28, 2006 12:10 am

Re: Screen Flash and Visual Effect

Post by RogGuay » Mon Aug 17, 2015 5:17 pm

Ken3D wrote:This is still happening. About 20% of the time when using a visual effect it flashes. Is this getting any attention? Does it need to be logged as a bug in order to get
I bugged it back in Dec of 2014 (#14036), and the last time I looked, I could not even find it in the queue! The problem has NOT gone away in any of the recent stable versions of LC and is still a big problem for me.

Thanks for your company . . . It's downright lonely in here!!

Ken3D
Posts: 16
Joined: Sun Mar 02, 2014 12:54 am

Re: Screen Flash and Visual Effect

Post by Ken3D » Mon Aug 17, 2015 9:29 pm

I posted a new bug for this and Hanson has confirmed and logged it. The bug number is 15734.

There does seem to be a eerie echo in here doesn't there.

Post Reply

Return to “Getting Started with LiveCode - Experienced Developers”