Page 1 of 1

Not all showing in iOS emulator

Posted: Sun Mar 30, 2014 4:07 pm
by DataDude
I have my stack set to 768 x 1024. I am using LC 6.6 build 4003. Test Target iPad simulator 7.0.

When I look at the app in development mode on my Mac it all looks and works fine. But when I start it in the emulator the application launches, but take up more area than the scree displays. So most of the application and all of the navigation is outside the display area.

I have tried playing with the various fullScreenMode settings and that does not seem to be helping.

Not quite sure what I did as the app was fitting onto the emulator screen previously.

Read the release notes on 5.5 and 5.6 to try to understand how the new scaling is used, but obviously haven't gotten the drift of what it is telling me.

Help!!
Thanks,
Tim G

Re: Not all showing in iOS emulator

Posted: Mon Mar 31, 2014 1:14 pm
by LCNeil
Hi Tim,

Is the iPad simulator fully on your screen or is this being cut off as well?

If the simulator is fully visible, then it is most likeley the new pixelScale property that is causing the issues. A discussion of this can be found in the following forum post-

http://forums.runrev.com/viewtopic.php?f=73&t=19739

If it is the iPad simulator that is too large fro your screen then you can set the scale factor of the simulator window via "Windows"---->"Scale" from the iOS simulator menu bar.

Please keep us posted on how you get on.

Kind Regards,


Neil Roger
--
RunRev Support Team ~ http://www.runrev.com
——

Re: Not all showing in iOS emulator

Posted: Mon Mar 31, 2014 10:19 pm
by DataDude
Simulator is fully visible.

This is what finally worked for me

on openStack
if the environment is "Mobile" then
set the pixelScale to 1
set the fullscreenmode of this stack to "exactFit"
end if
end openStack

I tried the same on the preOpenStack handler and that does not work. I also tried it without setting fullscreenmode to exactFit and it did not work without it, but with the pixelScale.

Thanks,
Tim G