Lesson 3 Help Needed

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
Pip
Posts: 47
Joined: Mon Jun 17, 2013 2:13 pm
Location: Perth, Western Australia

Lesson 3 Help Needed

Post by Pip » Fri Sep 13, 2013 4:28 pm

Still working away at lesson 3 & can not get the contacts card to display the database in the contacts field.

Keep getting an error in the script of the "databaseType" group but have checked it & the script is the "Lesson3Complete.Livecode" sample stack.

Screen shot of the script is attached, any guidance would be great, thanks.
Attachments
Screen Shot 2013-09-13 at 11.18.53 PM.png

Klaus
Posts: 10290
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: Lesson 3 Help Needed

Post by Klaus » Fri Sep 13, 2013 6:11 pm

Hi Pip,

where (in what script) is your "databaseconnect" handler?


Best

Klaus

Pip
Posts: 47
Joined: Mon Jun 17, 2013 2:13 pm
Location: Perth, Western Australia

Re: Lesson 3 Help Needed

Post by Pip » Sat Sep 14, 2013 2:05 am

Thanks Klaus

The card script was missing the "on openCard", all fixed now & can at last see the databased loaded in to contacts field.

Klaus
Posts: 10290
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: Lesson 3 Help Needed

Post by Klaus » Sat Sep 14, 2013 11:23 am

Hi Pip,

great, I love happy-ends :D


Best

Klaus

Pip
Posts: 47
Joined: Mon Jun 17, 2013 2:13 pm
Location: Perth, Western Australia

Re: Lesson 3 Help Needed

Post by Pip » Wed Sep 18, 2013 2:20 pm

Now have SQLite database working but when I select the Direct MySQL all the names disappear from the contacts field.

Have check the card script several times & can't see whats wrong & no error is returned, just a blank field.

Card script is attached, thanks for any help.
Attachments
Screen Shot 2013-09-18 at 9.11.59 PM.png
Screen Shot 2013-09-18 at 9.12.22 PM.png

elanorb
Livecode Staff Member
Livecode Staff Member
Posts: 251
Joined: Fri Feb 24, 2006 9:45 am

Re: Lesson 3 Help Needed

Post by elanorb » Wed Sep 18, 2013 2:48 pm

Hi Pip

Your code look ok from here, I would suggest putting a break point on line 30 to see if the code is getting to the part of the if statement you expect.

It might just be that the label of your Direct MySQL option button doesn't exactly match what you have in the if statement so the code is not being executed.

If that doesn't help please attach your stack or email it to me, elanor@runrev.com, and I would be happy to take a look.

Kind regards

Elanor
Elanor Buchanan
Software Developer
LiveCode

Pip
Posts: 47
Joined: Mon Jun 17, 2013 2:13 pm
Location: Perth, Western Australia

Re: Lesson 3 Help Needed

Post by Pip » Thu Sep 19, 2013 2:28 am

Thanks Elanor

The label of the direct MySql didn't match the script, all fixed now.

Pip

Post Reply

Return to “Summer School 2013”