Application Uploader Not work for .zip? - SOLVED

Got a LiveCode personal license? Are you a beginner, hobbyist or educator that's new to LiveCode? This forum is the place to go for help getting started. Welcome!

Moderators: heatherlaine, Klaus, FourthWorld, kevinmiller

Post Reply
DR White
Posts: 413
Joined: Fri Aug 23, 2013 12:29 pm
Location: Virginia, USA

Application Uploader Not work for .zip? - SOLVED

Post by DR White » Fri Feb 16, 2018 8:52 pm

I have been uploading .zip files to the Apple Store for year, but now I get the following error:

ERROR ITMS-90529: "Invalid package. Applications built with sdk 9.0 or later must be packaged as proper IPA files."

I have redone my App ID and Profiles several times, but cannot get rid of this error.

What does this mean? HELP!

Thank You,

David
Last edited by DR White on Sat Feb 17, 2018 1:35 am, edited 1 time in total.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 412
Joined: Fri Feb 06, 2015 4:03 pm

Re: Application Uploader Not work for .zip?

Post by LiveCode_Panos » Fri Feb 16, 2018 11:16 pm

Hi David,

You need to to submit a .ipa file, not a .zip one.

See the section "Convert to .ipa" of this lesson:

http://lessons.livecode.com/m/4069/l/33 ... -app-store

Best,
Panos
--

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 412
Joined: Fri Feb 06, 2015 4:03 pm

Re: Application Uploader Not work for .zip?

Post by LiveCode_Panos » Fri Feb 16, 2018 11:19 pm

Moreover, if you build with LC 8.1.9 and Xcode 9.2, you'll need to add an "AppStore Icon" in the iOS standalone settings (in the "Icons" section). This should be a 1024x1024 .png file.

Best,
Panos
--

DR White
Posts: 413
Joined: Fri Aug 23, 2013 12:29 pm
Location: Virginia, USA

Re: Application Uploader Not work for .zip?

Post by DR White » Sat Feb 17, 2018 1:35 am

Panos,

That took care my problem beautifully!!

Thanks SO MUCH,

David

Post Reply

Return to “Getting Started with LiveCode - Complete Beginners”