Submitting to App Store

Got a LiveCode personal license? Are you a beginner, hobbyist or educator that's new to LiveCode? This forum is the place to go for help getting started. Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller

Post Reply
tyarmsteadBUSuSfT
Posts: 135
Joined: Sat Aug 25, 2012 1:14 am

Submitting to App Store

Post by tyarmsteadBUSuSfT » Fri Nov 03, 2017 6:32 pm

I have tried multiple times to submit my update to the App store. It has been a while since the last submission so I used "http://lessons.livecode.com/m/4069/l/33 ... -app-store" but I am getting the error that the bundle is invalid. The IPA format requires a top-level director named Payload, containing only a .app bundle and optional pugins in a Plugins directory.
I followed the lesson step by step multiple times and still get error. Help...

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2377
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: Submitting to App Store

Post by jmburnod » Fri Nov 03, 2017 7:05 pm

Hi,
I think that a new version must work for iOS 11 and iOS 11 needs xCode 9 but
Xcode 9.1 is currently not (yet) supported by LC!
Best regards
Jean-Marc

tyarmsteadBUSuSfT
Posts: 135
Joined: Sat Aug 25, 2012 1:14 am

Re: Submitting to App Store

Post by tyarmsteadBUSuSfT » Mon Nov 06, 2017 6:13 pm

Thank you
Ty

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2377
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: Submitting to App Store

Post by jmburnod » Mon Nov 06, 2017 6:28 pm

Sorry,
I was wrong about necessity using xCode 9 to install on iOS 11.
Suddely, my partners can installed my app on iOS 11.1.
It is possible that my last error install was linked to other thing.
best regards
Jean-Marc

Post Reply

Return to “Getting Started with LiveCode - Complete Beginners”