Can't Turn Off LC Backdrop

Got a LiveCode personal license? Are you a beginner, hobbyist or educator that's new to LiveCode? This forum is the place to go for help getting started. Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller

bogs
Posts: 3698
Joined: Sat Feb 25, 2017 10:45 pm

Re: Can't Turn Off LC Backdrop

Post by bogs » Sat Sep 16, 2017 1:01 pm

jacque wrote:Normally you'd be right, deleting prefs is the first line of attack. But in this case the problem could be due to the new default behavior. It's a deviation from the norm.
Gotcha :)

I have to say, it was an interesting read to go through. I get that they were testing it as an aid to new users, to enable them to more fully follow the tutorial without distractions, and I could see that if the backdrop didn't completely cover the rest of your desktop. For instance, if the backdrop only covered the area directly behind the Lc working palettes, *that* might create the 'unified' look he was referring to.

Heck, if it only covered that area, I might use it myself :)

Hm. I wonder how hard that would be to figure out :roll:
Image

Steve Flavel
Posts: 3
Joined: Sun Mar 27, 2016 6:30 pm

Re: Can't Turn Off LC Backdrop

Post by Steve Flavel » Sun Sep 17, 2017 9:52 pm

Thanks for the link, I think I had read that.
What is interesting is that on reset preferences the backdrop colour is set to white, but on opening Livecode again the backdrop is grey.
My workaround is to put this in the project's preOpenStack handler

if licensed() then # Returns true if the development environment is running.
set the backdrop to none
end if
Then open live code by double clicking my project file.
However it is frustrating. It happened when I
Deleted all versions of Livecode using CleanMyMac
Installed the latest livecode 9
Then after I had a play. Deleted that version then installed a fresh version of 8.1.7 rc1
How can I make my background choice in preferences stick?

bogs
Posts: 3698
Joined: Sat Feb 25, 2017 10:45 pm

Re: Can't Turn Off LC Backdrop

Post by bogs » Mon Sep 18, 2017 11:04 am

jacque wrote:Sounds similar. If you follow the thread to the end, Mark Wieder had a sequence of steps that fixed it.
I think Jacque was referring to this post
Mark Wieder via use-livecode Wed, 19 Jul 2017 12:38:34 -0700 wrote:
On 07/18/2017 10:59 PM, Ali Lloyd via use-livecode wrote: wrote: Do your keyboard shortcuts work Mark? You could use Ctrl+M to pop open the
message box, and set the backdrop to none, then toggle it on and off via
the View menu, then hopefully it should be gone from your preferences.
Interesting. That didn't work for me, but the following did:
.. launch LC9
.. get a completely gray screen
.. alt-tab my way to LiveCode
.. now the menubar and other palettes are in front of the backdrop
.. disable the backdrop to set the preference

so everything's there, it's just that the backdrop is in front of all other windows and it's not passing (keyboard) events through.
Mark Wieder
Jacque herself had an interesting tidbit in that thread,
J. Landman Gay via use-livecode Tue, 18 Jul 2017 22:27:21 -0700 wrote: Don't know if it helps, but I didn't see this behavior. I frequently turn on the backdrop when screen sharing and turn it off later. I wonder if the problem only occurs if there is no preference set yet?
What I take this to mean is that if you have an earlier version which set preferences installed (not sure which vers. prefs 9 might also use? 7x? 8x? ) where you had turned off the backdrop, then installed 9 that has the problem, the issue doesn't present itself.

So in that one thread there were actually 2 ways to try to work around it. Since your telling us Mark's didn't solve it (setting it in 9's prefs), perhaps just removing everything one more time, including the prefs files, then installing an older working version, setting the pref, (making sure backdrop off seting works), and installing 9 after that will ?

Sounds like a right pita, but I am sure we've all seen or dealt with worse, I know I have.
Image

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5084
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Can't Turn Off LC Backdrop

Post by jacque » Mon Sep 18, 2017 5:05 pm

It might be easier than that. Install an older version, launch it, toggle the backdrop a couple of times to set the preferences up. Quit. Launch LC 9 and it should honor the setting.

LC 8 and 9 share the same prefs file. Next time you clean up the Mac, don't delete it.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

bogs
Posts: 3698
Joined: Sat Feb 25, 2017 10:45 pm

Re: Can't Turn Off LC Backdrop

Post by bogs » Mon Sep 18, 2017 8:12 pm

bogs wrote:What I take this to mean is...
jacque wrote:It might be easier than that.
Smarty :P
Image

Post Reply

Return to “Getting Started with LiveCode - Complete Beginners”