Can't Turn Off LC Backdrop

Got a LiveCode personal license? Are you a beginner, hobbyist or educator that's new to LiveCode? This forum is the place to go for help getting started. Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller

deadparrotsoftware
Posts: 40
Joined: Thu Mar 24, 2016 6:56 pm
Location: Orlando FL
Contact:

Can't Turn Off LC Backdrop

Post by deadparrotsoftware » Sun Apr 03, 2016 3:46 am

Ever since I turned on the backdrop in LC (to white) in Ver 8 DP 16 (on windows 8.1) it has been behaving erratically.

But there does not seem to be any way to turn the backdrop back off! Even the "Restore To defaults" button does nothing. It is extremely frustrating.

Joe C.

IGNORE THIS POST - turned out to be a windows thing. The view setting was not turning the backdrop off, but it was something in widows causing it to stay in place. Turning Backdrop OFF and then restarting LC cleared the backdrop. I hate windows :-)
http://AppBuzzinga.com - App Making Software, Source Code, & Information
Win, MAC, Android, Apple, WordPress

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 7024
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Can't Turn Off LC Backdrop

Post by FourthWorld » Sun Apr 03, 2016 5:14 am

deadparrotsoftware wrote:I hate windows :-)
It's never too late to try Ubuntu. :)

Cross-platfrom tools like LiveCode let me deploy to Windows, Mac, and Linux from any of them I happen to be enjoying in a given week. Lately I've been working on Ubuntu and having a good time with it.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

FredBeck
Posts: 77
Joined: Fri Nov 01, 2013 3:07 pm
Location: Paris
Contact:

Re: Can't Turn Off LC Backdrop

Post by FredBeck » Sun Apr 03, 2016 2:44 pm

It's never too late to try Ubuntu. :)
Funny! As a matter of fact I'm trying lubuntu since yesterday, and the backdrop appears in front of everything. If I didn't have a second screen I would've had to kill lc in the console...

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 7024
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Can't Turn Off LC Backdrop

Post by FourthWorld » Mon Apr 04, 2016 4:40 pm

Which version of LiveCode are you using? The issue you described was reported as fixed some time ago, but unfortunately a less onerous issue in which the backdrop isn't sized correctly has regressed since:
http://quality.livecode.com/show_bug.cgi?id=16131

The team is working on these, so I'm hoping they'll be addressed in v8,0 soon.

Why Lubuntu specifically, instead of Mint or Ubuntu?
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

deadparrotsoftware
Posts: 40
Joined: Thu Mar 24, 2016 6:56 pm
Location: Orlando FL
Contact:

Re: Can't Turn Off LC Backdrop

Post by deadparrotsoftware » Mon Apr 04, 2016 5:06 pm

It has re-broken I am afraid. :-)

LC behaves flaky (on windows) when backdrop is up. You can turn it off in view, but it re-appears every time at the start of LC. There is no setting for "no backdrop" in preferences, and the "reset preferences to default" button does not reset anything, as near as I can tell.

Watching the weirdness when backdrop is in place, I get the feeling that messages are being interfered with, or reacted to by wrong stack.

Joe C.
http://AppBuzzinga.com - App Making Software, Source Code, & Information
Win, MAC, Android, Apple, WordPress

FredBeck
Posts: 77
Joined: Fri Nov 01, 2013 3:07 pm
Location: Paris
Contact:

Re: Can't Turn Off LC Backdrop

Post by FredBeck » Mon Apr 04, 2016 6:51 pm

Richard, it's LC8 dp 16. I didn't install LC7 yet.
and why lubuntu? I don't know... I'm a little more familiar with lxde and they say it's superlight.
I must say I quite like it so far. Even have windows on a virtual machine now!

Steve Flavel
Posts: 3
Joined: Sun Mar 27, 2016 6:30 pm

Re: Can't Turn Off LC Backdrop

Post by Steve Flavel » Fri Sep 15, 2017 12:31 am

This has reappeared in 8.1.7 rc1 and 8.2.0 dp1
Resetting all preferences clears it, but it returns when live code is opened again.
How can I turn it off permanently?

Regards

Steve F

bogs
Posts: 3997
Joined: Sat Feb 25, 2017 10:45 pm

Re: Can't Turn Off LC Backdrop

Post by bogs » Fri Sep 15, 2017 12:10 pm

You could try deleting the preferences file, from my understanding, Lc rebuilds it on restart.
Image

Steve Flavel
Posts: 3
Joined: Sun Mar 27, 2016 6:30 pm

Re: Can't Turn Off LC Backdrop

Post by Steve Flavel » Fri Sep 15, 2017 8:10 pm

Deleting the preference file did not work.
Is there a cache somewhere? I am on OSX 10.12.6

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5155
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Can't Turn Off LC Backdrop

Post by jacque » Fri Sep 15, 2017 9:44 pm

If I remember right, LC changed the behavior so that on first launch (when there is no current prefs file yet) it will show the background by default. If you already have a prefs file, it should honor the setting. I have never seen the backdrop because I had a previous prefs file already with that setting turned off. But if you installed with no prefs file in place, it sounds like there's a bug that isn't retaining your new choice.

If there was no LC installation on your Windows machine before this started happening, I'd report it. Or maybe report it even if you already had a prefs file. If my guess is correct, deleting the prefs file would make it worse because LC would consider it a "new" installation.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

bogs
Posts: 3997
Joined: Sat Feb 25, 2017 10:45 pm

Re: Can't Turn Off LC Backdrop

Post by bogs » Fri Sep 15, 2017 10:29 pm

jacque wrote: If my guess is correct, deleting the prefs file would make it worse because LC would consider it a "new" installation.
My bad if it does make it 'worse', my assumption is that if something was wonky with the previous prefs file, having it create a new one and then changing the setting should *fix* it.

Of course, if you already can't get rid of the backdrop, then I don't see how it could be made worse if you still can not.
Image

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5155
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Can't Turn Off LC Backdrop

Post by jacque » Fri Sep 15, 2017 10:40 pm

Normally you'd be right, deleting prefs is the first line of attack. But in this case the problem could be due to the new default behavior. It's a deviation from the norm.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 7024
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Can't Turn Off LC Backdrop

Post by FourthWorld » Fri Sep 15, 2017 11:07 pm

FWIW in v8.2dp1 under Ubuntu 14.04 the backdrop works well, off by default and on when I use the "set the backdrop..." command.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5155
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Can't Turn Off LC Backdrop

Post by jacque » Fri Sep 15, 2017 11:18 pm

FourthWorld wrote:FWIW in v8.2dp1 under Ubuntu 14.04 the backdrop works well, off by default and on when I use the "set the backdrop..." command.
Did you already have a pre-existing prefs file? I think the default-on behavior only happens with a new install. But I'm working on what may be a faulty memory of one of the release announcements recently.

Also, I'd guess the OP is using the menu item rather than the message box, so there may be a disconnect in the menu itself. Who knows.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5155
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Can't Turn Off LC Backdrop

Post by jacque » Fri Sep 15, 2017 11:24 pm

Just found this:
https://www.mail-archive.com/use-liveco ... 87178.html

Sounds similar. If you follow the thread to the end, Mark Wieder had a sequence of steps that fixed it.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

Post Reply

Return to “Getting Started with LiveCode - Complete Beginners”