Page 1 of 1

JDK Installer

Posted: Mon Apr 22, 2013 5:15 am
by cusingerBUSCw5N
My computer had a virus and in the process of fixing it, it wiped out my JDK files (When you used the start menu and clicked on Android SDK, it had "empty". Because of this, my Livecode won't run in test mode. So I am trying to reinstall JDK - unsuccessfully.

First, I installed Java jdk1.7.0_21 Image. It seems to be in the Programs folder, everything seems OK.

Then, I installed Android SDK....or maybe I didn't. It wouldn't let me download it in the programs folder, so I downloaded it in my docs folder. (I tried switching to administrative mode, and am not too sure I succeeded there either. I set everything for all access - but it still wouldn't let me save it in the programs folder.) Anyway, when I installed (or tried to install) the Android SDK, I got the results in the image below. I THINK that the image here says that some of the items are already installed, but I don't know where they are located on my computer...and clicking "install 1 package" didn't seem to do anything....

or maybe it is already the wrong place???

I also set up the Environment Variables JAVA_HOME to c:\program files\java\jdk1.7.0_21 - which is where the java is. (although somewhere in the back of my mind, the first time I had to use jdk1.6.0_45 (but I tried that today and it doesn't work either).

All I know is when I open up Livecode, the Standalone Application settings are clicked for Android, but the test environment is dim in the Development dropdown - and there is nothing in my Start menu anymore for Android SDK...

As you can see, I've tried all these random things, but really don't know what I'm doing.

This used to work, but unfortunately, I can't figure out how to make it work again. HELP!!!! :?

Re: JDK Installer

Posted: Mon Apr 22, 2013 6:47 am
by cusingerBUSCw5N
OK. I got further I went back and installed the 2.2 API 8 - per LiveCode's instructions ( ... er-on-a-pc)....

it worked. Then I went into Tools at the top and installed a virtual device - per the same instructions. Everything's looking good - Then it said to start the Emulator. I finally realized that I had to click the virtual device I wanted, and then the start button appear. So I started it. YEAH!!!

The only bad news is that my LiveCode still doesn't have a test target lit up in development. I do, however, have a lovely screen showing the virtual device...

Just realized that I have to do some more work in Preferences on the LIvecode Lesson - but it's too late tonight. Hopefully this will be resolved tomorrow without your help.