Unicode problem in text field on Univesity stack

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, asayd

Unicode problem in text field on Univesity stack

Postby penopia » Tue Dec 24, 2013 4:35 am

Thanks for providing LiveCode University, It make it very easy & fun to learn Livecode.
I have difficulty to read the main text field because some characters are broken.
I suspect this problem might be caused from Unicode system.
I use Korean (2 byte character) and the broken texts are suspected to be the special characters like "'"
I hope this to be fixed, becasue most asians, Japenese, Chinease.. may have the same problems

Regards
penopia
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 22
Joined: Fri Apr 25, 2008 2:46 pm

Re: Unicode problem in text field on Univesity stack

Postby asayd » Thu Jan 02, 2014 7:13 pm

Hi penopia,

Is there any way you could post a screen shot of what you are seeing? This could help figure out what is going wrong.

Thanks,

Devin
Devin Asay
Learn to code with LiveCode University
https://livecode.com/store/education/
asayd
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 94
Joined: Mon Apr 10, 2006 7:02 pm
Location: Provo, Utah, USA

Re: Unicode problem in text field on Univesity stack

Postby penopia » Sat Jan 04, 2014 5:28 am

Dear Devin;

I can't find the way to attach the image.
If you let me know your E-mail address, I'll send the screeensot.

Regards.
penopia
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 22
Joined: Fri Apr 25, 2008 2:46 pm

Re: Unicode problem in text field on Univesity stack

Postby asayd » Sat Jan 04, 2014 4:26 pm

penopia,

Look for the "Img" tab at the top of the reply field. Click it and it will insert [img\][/img] tags. The just insert a URL between the tags, e.g.: http://server.com/image.png. Of course, you have to have a web server you can upload to.

If this doesn't work, email me at devin[underscore]asay[at]byu[dot]edu.

Devin
Devin Asay
Learn to code with LiveCode University
https://livecode.com/store/education/
asayd
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 94
Joined: Mon Apr 10, 2006 7:02 pm
Location: Provo, Utah, USA

Re: Unicode problem in text field on Univesity stack

Postby penopia » Sun Jan 05, 2014 4:19 pm

To Levin
I sent you an email, please find attached screen shot.
I circled around the brocken characters.
penopia
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 22
Joined: Fri Apr 25, 2008 2:46 pm

Re: Unicode problem in text field on Univesity stack

Postby asayd » Mon Jan 06, 2014 8:23 pm

Yes, you're right, it does look like a unicode rendering problem. Odd, because I store the lesson text as UTF-8. I wonder if the font is mapping incorrectly. It shouldn't be a problem, because LCU uses a font that ships with it and loads dynamically on startup.

The incorrect characters appear where there would normally be "curly" or "smart" quotes. Are the characters that appear actual valid Korean characters?

I see you are using Windows. Can you tell me about your Windows configuration? What OS version, and do you have Korean set as the system font?

Devin
Devin Asay
Learn to code with LiveCode University
https://livecode.com/store/education/
asayd
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 94
Joined: Mon Apr 10, 2006 7:02 pm
Location: Provo, Utah, USA

Re: Unicode problem in text field on Univesity stack

Postby penopia » Tue Jan 07, 2014 5:02 am

Dear Devin

The broken characters are also meaningless in Korean.

I use Window XP with Korean text setting. But I don't think this is the cause, because I have no problem using other programs such as LIVECODE, kindle eBook, ...

Considering that LIVECODE uses UTF-16, and it runs perfectly well, I suspect this minor problems may be originated from the difference between UTF-8 and UTF-16.

I made several livecode stack using Korean text set. But when unicode mismatches, all the text are un-readable. I haven't see the problems happen sporadically only in some characters.

Anyway, I can read the text (becasue the unreadable texts are rare) and proceed the university course. It's the curiosity thing that bothers me, why this problems happen.

Thank again for your help to solve this problems

Best regards
Park.
penopia
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 22
Joined: Fri Apr 25, 2008 2:46 pm

Re: Unicode problem in text field on Univesity stack

Postby penopia » Tue Jan 07, 2014 5:11 am

Dear Devin;

Yesterday, I installed University stack in my Mac at home and there was no problems even I use Korean text set. The problems seems to be related system OS.

Yours, Park
penopia
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 22
Joined: Fri Apr 25, 2008 2:46 pm

Re: Unicode problem in text field on Univesity stack

Postby asayd » Tue Jan 07, 2014 5:20 pm

Park,

Glad to hear that it's working properly on your Mac. I went back and checked my source texts, and reminded myself that the characters that are not rendering properly for you are actually stored as HTML entities, not as unicode. So it makes me wonder if there might be some problems with LiveCode rendering HTML entities on Windows XP. When I get a chance I'll do some testing. I may send you a LiveCode stack to test on your XP system.

Regards,

Devin
Devin Asay
Learn to code with LiveCode University
https://livecode.com/store/education/
asayd
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 94
Joined: Mon Apr 10, 2006 7:02 pm
Location: Provo, Utah, USA


Return to LiveCode University

Who is online

Users browsing this forum: No registered users and 1 guest