building LC for MacOSX: "BUILD FAILED"

Moderators: FourthWorld, heatherlaine, Klaus, kevinmiller, LCMark

building LC for MacOSX: "BUILD FAILED"

Postby Thierry » Thu Nov 12, 2015 12:13 pm

Hi,

Trying to build the Livecode engine with Xcode 7.1 and against MacOS.10.11 SDk
I'm stuck with :

** BUILD FAILED **

Code: Select all
./livecode/engine/src/coretextfonts.cpp:495:21: error:
                  use of undeclared identifier 'ATSUFindFontFromName'
        t_success = ATSUFindFontFromName(t_name, t_name_length, kFontPostscriptName, ....
                    ^
17 warnings and 1 error generated.


The following build commands failed:
   CompileC ./livecode/_cache/mac/Debug/kernel.build/Objects-normal/i386/coretextfonts.o src/coretextfonts.cpp normal i386 c++ com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)
make[1]: *** [compile-mac] Error 65
make: *** [all-mac] Error 2


Thanks for any help,

Thierry
Thierry Douez - https://sunny-tdz.com
sunnY(rex - text2speech - perl - midi - image - pdf)
Thierry
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 537
Joined: Wed Nov 22, 2006 3:42 pm
Location: France

Re: building LC for MacOSX: "BUILD FAILED"

Postby monte » Fri Nov 13, 2015 6:20 am

@LCFraser is in the middle of implementing 64 bit support for Mac which also resolves all or most of the reasons we can't currently build against anything higher than 10.9. Here's the relevant PR to your error https://github.com/livecode/livecode/pull/3167
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/
monte
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 1557
Joined: Fri Jan 13, 2012 1:47 am

Re: building LC for MacOSX: "BUILD FAILED"

Postby Thierry » Fri Nov 13, 2015 8:41 am

monte wrote:we can't currently build against anything higher than 10.9

Thanks, back to 10.9 then...
Thierry Douez - https://sunny-tdz.com
sunnY(rex - text2speech - perl - midi - image - pdf)
Thierry
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 537
Joined: Wed Nov 22, 2006 3:42 pm
Location: France

Re: building LC for MacOSX: "BUILD FAILED"

Postby peter-b » Fri Dec 18, 2015 12:17 pm

Unfortunately the MacOSX 10.11 SDK has removed quite a lot of APIs that the 32-bit version of LiveCode relies on. I'm actually installing Xcode 6.4 at the moment so that I can get LiveCode to build on OS X 10.11!

I know that Fraser currently plans to update all those bits as part of the 64-bit Mac support work.
LiveCode Open Source Team — @PeterTBBrett — peter.brett@livecode.com
peter-b
 
Posts: 182
Joined: Thu Nov 20, 2014 2:14 pm
Location: LiveCode Ltd.

Re: building LC for MacOSX: "BUILD FAILED"

Postby Thierry » Wed Apr 19, 2017 11:18 am

Hi,

What are the official latest versions of Xcode and MacOS SDK to
be able to build liveCode on OS X 10.12?

Thanks,

Thierry
Thierry Douez - https://sunny-tdz.com
sunnY(rex - text2speech - perl - midi - image - pdf)
Thierry
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 537
Joined: Wed Nov 22, 2006 3:42 pm
Location: France


Return to Engine Contributors

Who is online

Users browsing this forum: No registered users and 1 guest