test_harness.rev

Moderators: heatherlaine, Klaus, FourthWorld, kevinmiller, LCMark

Post Reply
monte
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 1559
Joined: Fri Jan 13, 2012 1:47 am
Contact:

test_harness.rev

Post by monte » Thu Jan 02, 2014 4:28 am

I tried building test_harness.rev for iOS 7 via the buildComponents command and a few modifications (added in 6.1 and 7.0 sdk, removed 6.0 sdk and removed references to Linked components because they don't exist in the runtime folders) and it didn't work... Any clues?... Well... it launches in the simulator then jumps to the debugger as soon as the stack is drawn and Xcode won't deploy it to my phone because of architecture issues...

Ideally we might get to a point where the externals sdk is just embedded in the livecode repo and building lcidl might build the test harness standalones but I guess that would need a command line standalone builder. Might we be able to skip the test harness if we rename our test stacks iphone_test.livecode though?
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

monte
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 1559
Joined: Fri Jan 13, 2012 1:47 am
Contact:

Re: test_harness.rev

Post by monte » Thu Jan 02, 2014 4:34 am

Hmm... it appears to work in the simulator now... still getting the architecture issue on device though....
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

monte
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 1559
Joined: Fri Jan 13, 2012 1:47 am
Contact:

Re: test_harness.rev

Post by monte » Thu Jan 02, 2014 4:55 am

Ah.. the device builds of the test harness are turning out to be 0 bytes...
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

LCMark
Livecode Staff Member
Livecode Staff Member
Posts: 970
Joined: Thu Apr 11, 2013 11:27 am

Re: test_harness.rev

Post by LCMark » Thu Jan 09, 2014 11:51 am

@monte:
Ah.. the device builds of the test harness are turning out to be 0 bytes...
That suggests something is throwing an error when building the executable - some of the scripts will still 'succeed' even if they fail thus not necessarily coming up as a build error in Xcode (if I recall correctly).
Ideally we might get to a point where the externals sdk is just embedded in the livecode repo and building lcidl might build the test harness standalones but I guess that would need a command line standalone builder. Might we be able to skip the test harness if we rename our test stacks iphone_test.livecode though?
Well the test harness approach was pre-opensource - when third-parties didn't have access to the engine-mobile xcodeproj. One option now would be to ditch the 'test_harness' and instead tie external xcodeproj's to the engine-mobile project. i.e. When you build your external in xcode to test it, it makes sure it has the appropriate engine built, links the external to it and then gets xcode to launch on the device thus obviating the need for pre-canned 'test' engines. It would be easy enough to tweak the mobile startup so that it used an environment variable to decide which stack within the app bundle to load as the mainstack.

monte
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 1559
Joined: Fri Jan 13, 2012 1:47 am
Contact:

Re: test_harness.rev

Post by monte » Fri Jan 10, 2014 1:04 am

Sounds great... just getting the debugger working again in the simulator helped me resolve a couple of nagging issues.
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Post Reply

Return to “Engine Contributors”