Code: Select all
filter thelist with item 3 of each is "foo"...
A LiveCoder who reads the first part of the sentence and takes it literally "Filter the list with item 3..." may understand it as lists with item 3 will be filtered.
"Filter thelist with item 3 of each is "foo" now is harder to take literally and understand.
Taken literally "Filter thelist where item 3 of each is "foo" makes sense.
Also "Filter thelist where item 3 of each is not "foo" also makes sense when taken literally than "filter thelist" without item 3 of each is "foo"
I am not sure how many average users read the engine contributors forum and would be involved in this discussion but I think it would be good to get their(our) input on some of these syntax changes.
Perhaps before Jan gets down to working on the project it would be a good idea to have a post in one of the general forums or on the use list summarizing the possible syntaxes and get the feedback from the broader community as to what would make the most sense to them.