Android API required api level

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
cusinger3
Posts: 7
Joined: Mon May 13, 2019 11:44 pm

Android API required api level

Post by cusinger3 » Fri Jun 28, 2019 11:42 pm

Hi. I am working to comply with Google's new requirement for higher API levels beginning August 1st. I downloaded the newest version of Indy (this forum won't let me type in the version without creating errors), but it is nine point five. I downloaded the Q SDK package in Android Studio and created a new project. I created my standalone app and uploaded it to Google, and it still says that I don't comply because the API level is too low.

What else was I supposed to do?

Thanks! :D

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5136
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Android API required api level

Post by jacque » Sat Jun 29, 2019 4:34 pm

You don't need to compile with Android Q, though it probably won't hurt. Instead you need to update the manifest to use the required target version. This is different from the app version or the SDK version. The basic idea is to create a copy of the default manifest from your apk, edit the target version, and then rebuild using your edited manifest. You include the edited manifest in the Copy Files pane of the standalone settings.

There's more discussion here, though I couldn't find the post that was a little more explicit:
https://forums.livecode.com/viewtopic.p ... on#p167458
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 586
Joined: Fri Feb 06, 2015 4:03 pm

Re: Android API required api level

Post by LiveCode_Panos » Mon Jul 01, 2019 12:46 pm

Hello all,

This issue will be addressed in the next release of LC 9.5

Kind regards,
Panos
--

markhinnebusch
Posts: 39
Joined: Thu May 17, 2018 7:32 pm
Location: Florida, USA

Re: Android API required api level

Post by markhinnebusch » Fri Sep 06, 2019 8:32 pm

I am trying to use the "manifest in copy files" solution to a different problem, that is, to make Chromebook not try to resize my app. When I build with my manifest, it works fine on an Android but the chromebook won't install the app, saying there is a problem parsing the package.

I need to disable resizing since it works if your initial orientation is portrait but not if it is landscape, which ours needs to be since it is destined for a laptop/chromebook format.

Any idea if the fix mentioned above in the next 9.5 release might solve this problem too? I don't know where to go from here.

Post Reply

Return to “Android Deployment”