Page 1 of 1

SDK folder is not valid?

Posted: Mon Sep 17, 2018 5:42 am
by EdPayne
Suddenly, the path for Android SDK is missing in my settings.

When I try to choose the same SDK that worked the other day I get:

"The chosen folder is not a valid Android SDK. Please ensure you have installed it correctly.
and enabled support for Android 4.0.3 (API 15)"

I used this SDK two days ago when I last updated my app on Google Play, and now this? Update! Showbox caused it. It's fixed now!

I have not done any updates or installations, so what might have happened, and how do I fix the problem?
Ideally without having to reinstall the entire SDK, If it happened once it can happen again.

I'm on a MAC using LC 9.0.0 (dp11)

Re: SDK folder is not valid?

Posted: Mon Sep 17, 2018 10:05 am
by LiveCode_Panos
Hello EdPayne,

1. What are the contents on the root sdk folder that you choose?

2. Why are you still using LiveCode 9.0 DP-11? We have released several newer versions since then, The most recent is LiveCode 9.0.1:

https://downloads.livecode.com/livecode/

Note than in recent LC versions the Android requirements have slightly changed, to comply with Google's new rules for app submission to the store.
So starting from LC 9.0.1 RC-1, you should make sure you have enabled support for Android 8.0 (API 26).

Kind regards,
Panos
--