Page 1 of 1

Could not encode class bundle

Posted: Sat Aug 18, 2018 4:05 pm
by wfr747
Hi,

I'm new to LC and I have the following problem:
I receive the folllwing error message, when I try to make an Android standalone app:
error.JPG
My Windows version is Win 10,
LC 9.0.1 (rc 1) Community
Android Studio 3.1.4

My mobile support preferences:
mobile_support.JPG
mobile_support.JPG (15.54 KiB) Viewed 826 times
the installed Android Studio components:
android_studio_settings.JPG
What can I do?

Thank you
Walter

Re: Could not encode class bundle

Posted: Sun Aug 19, 2018 6:11 pm
by jacque
Did you also install the build tools?

Re: Could not encode class bundle

Posted: Mon Aug 20, 2018 9:28 pm
by wfr747
Hi Jacqueline,

Thank you for your reply,

No, I did not install the build tools. Do I need them too?

Thank you
Walter

Re: Could not encode class bundle

Posted: Tue Aug 21, 2018 12:22 am
by jacque
wfr747 wrote:
Mon Aug 20, 2018 9:28 pm
No, I did not install the build tools. Do I need them too?
Yup. They are what LC uses to...build. :) Install the latest version and if that doesn't work, install the next-to-latest version. I can't remember which one is required.

Re: Could not encode class bundle

Posted: Tue Aug 21, 2018 5:50 pm
by wfr747
Hi Jacqueline,

Sorry, I was not clear enough. What I was trying to say, do I need a seperate program to install the SDK Build Tools, or is is enough to activate the checkbox within Android Studio (which I did):
android_studio_sdk_tools.JPG
Thank you
Walter

Re: Could not encode class bundle

Posted: Tue Aug 21, 2018 6:18 pm
by jacque
I don't use Studio so I'm not sure but I'd think it would work. I use the plain command line tools but Studio seems to reflect the same files.