Building for Android

The place to discuss anything and everything about running your LiveCode on Android

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
Ivorp
Posts: 5
Joined: Wed May 23, 2018 12:48 pm

Building for Android

Post by Ivorp » Thu Jul 26, 2018 4:27 pm

hi

is it necessary to have Android studio / Android SDK installed to compile APK for Android? I have given up trying to run an emulated version and just load the APK to my phone so do i need this massive application? To be clear what is the minimum required to compile for Android?

many thanks

Ivor

Klaus
Posts: 10381
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: Building for Android

Post by Klaus » Thu Jul 26, 2018 4:37 pm

Hi Ivor,

yes, the SDK or Studio is mandatory for LC to compile for Android!
I do not develop for mobile (nor do I own a cellphone or any mobile device) so I cannot answer your other question.


Best

Klaus

Ivorp
Posts: 5
Joined: Wed May 23, 2018 12:48 pm

Re: Building for Android

Post by Ivorp » Thu Jul 26, 2018 4:40 pm

ok thanks - can 'anyone' tell me the exact versions of JAVA SDK / Android SDK and their locations please? the last time i tried this it was a nightmare to configure (latest versions not working with LC ect) so hoping that there is some clear contemporary instructions i can follow?

cheers

Ivor

Klaus
Posts: 10381
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: Building for Android

Post by Klaus » Thu Jul 26, 2018 4:56 pm

Hi Ivor,

I only know that Jave 8.x is the latest supported JAVA version for Android development.
Will move this thread to the "Android" forum now (hint, hint 8) )


Best

Klaus

Ivorp
Posts: 5
Joined: Wed May 23, 2018 12:48 pm

Re: Building for Android

Post by Ivorp » Thu Jul 26, 2018 5:32 pm

ok thanks i will check it there

cheers

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4658
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Building for Android

Post by jacque » Fri Jul 27, 2018 6:33 pm

Android Studio is not required and I have never installed it. The SDK is always required regardless of whether you use Studio or not. You can install the SDK independently. You also need Java 8 as Klaus said.

The SDK must include the Android 4.0.3 files at a minimum, and you can add any newer versions if you want. You will also need the latest version of the build tools (unless LC specifies otherwise in the online lesson.)

I'm not at my Mac right now but do a search in the lessons for "How to become an Android developer" and it should pop up. There used to be a conflict with the latest build tools but I'm not sure if that's been resolved yet or not.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

Post Reply

Return to “Android Deployment”