SDK folder is not valid?

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
Peter@multidesk.se
Posts: 125
Joined: Fri Oct 14, 2011 6:53 am

SDK folder is not valid?

Post by Peter@multidesk.se » Fri Feb 02, 2018 11:19 am

Suddenly, the path for Android SDK is missing in my settings.

When I try to choose the same SDK that worked the other day I get:

"The chosen folder is not a valid Android SDK. Please ensure you have installed it correctly.
and enabled support for Android 4.0.3 (API 15)"

I used this SDK two days ago when I last updated my app on Google Play, and now this?

I have not done any updates or installations, so what might have happened, and how do I fix the problem?
Ideally without having to reinstall the entire SDK, If it happened once it can happen again.

I'm on a MAC using LC 9.0.0 (dp11)


///Peter
/*Whats all the fuss with c# ?*/

ameguira@gmail.com
Posts: 17
Joined: Mon Apr 18, 2016 4:57 pm

Re: SDK folder is not valid?

Post by ameguira@gmail.com » Tue Feb 13, 2018 7:42 pm

Hi Peter
I am facing the same problem.
I have installed Android latest version and it seems that LC could be not compatible with it.
I think that we should downgrade the version.
Hope somebody got the solution for us.
Good luck

batmanandjoker
Posts: 1
Joined: Mon Apr 16, 2018 2:04 pm

Re: SDK folder is not valid?

Post by batmanandjoker » Mon Apr 16, 2018 2:12 pm

I also had the hassle of "the chosen listing is not a valid domestic for Android SDK", even when I had updated SDK. (I had an eclipse installation already, that become outdated) as soon as I ran Android Studio with admin rights, i was capable of set the Android SDK path to the sdk folder in my eclipse instalation that I up to date. – Xilconic may 30 'thirteen at 20:thirteen
Admin rights do not solve this hassle. One has to absolutely uninstall and reinstall Android Studio! –
ShowBox Kodi

adxsoft
Posts: 11
Joined: Wed Apr 11, 2018 12:25 pm

Re: SDK folder is not valid?

Post by adxsoft » Wed Feb 20, 2019 6:07 am

I'm having exactly the same problem on Mac OSX 10.11.5, tried LC 8.1.8, LC 9.0.0 and 9.02. Worked yesterday and haven't changed anything overnight so this a major issue for me. Hopefully the cause and solution will be found asap.
Allan

adxsoft
Posts: 11
Joined: Wed Apr 11, 2018 12:25 pm

Re: SDK folder is not valid?

Post by adxsoft » Wed Feb 20, 2019 6:23 am

I solved this for my situation hopefully will work for others.

I noticed that the error message I got said the Android version API 26 was not present. Went into Android Studio, Preferences, Appearance & Behaviour, System Settings,Android SDK and saw Android Version for API 26 was not ticked. I ticked that and clicked the download icon (on the left) and the API 26 version was downloaded automatically.

Once I had the API 26 version of the Android SDK installed I was able to to go to Livecode, Preferences, Mobile Support and set the the location of Android SDK successfully.

So it seems the older version of the Android SDK I was using API 19 (Kitkat) is no longer supported by Livecode.

Can one of LC support team confirm this is the case.

Cheers
Allan

Post Reply

Return to “Android Deployment”