Minimum Android Version is not selectable on Pref.

The place to discuss anything and everything about running your LiveCode on Android

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
teriibi
Posts: 254
Joined: Mon Nov 13, 2017 3:49 pm
Location: Bolivia

Minimum Android Version is not selectable on Pref.

Post by teriibi » Sat Jan 20, 2018 3:05 am

Hi,
My first trial to produce an APK finaly produced a "corrupted file" error :D
I Realized that the minimum Android version shows up to 5.1
(My Android device is running 7.1.1)
So far...so logical, the apk might not be corrupted.. most likely set with the wrong min¦ version

PROBLEM: What I cant figure out is why is my list of available Android Versions ending at 5.1...
while My Android SDK shows installed versions of 4.0, 7.0 plus 7.1 installed ¿

Would this come from a Mess instalation or some Version Comunity Plus 9.0 limits ?
...or what else can "hide" to the LC pref. those 7.xx versions ?
:roll:
thanks for your ligths !
Image
Attachments
MINIMUM VERSIONS.png

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4622
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Minimum Android Version is not selectable on Pref.

Post by jacque » Sat Jan 20, 2018 6:50 pm

The minimum version is the lowest version the app can use. The Play Store will not show the app to users who run OS versions lower than the minimum. But devices with newer OS versions can run the app, so setting the minimum does not affect newer devices.

The corruption isn't because of the version, it is something else. It isn't clear where that error displays. Does it happen during the build? Are you able to compile? What is the complete error message? How far does the build process go before the error occurs?

A corrupted stack message is a LC error and usually means something is wrong with the stack file.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

teriibi
Posts: 254
Joined: Mon Nov 13, 2017 3:49 pm
Location: Bolivia

Re: Minimum Android Version is not selectable on Pref.

Post by teriibi » Sun Jan 21, 2018 2:37 am

Oh, ok, so I m good with the Minimum version.
The building and testing of the stack is fine. It all ends with success.

Apk instalation on device.
- I transfered the APK to my tablet (BTW running a Lineage version 7.1.1) all App from playstore install without problems.
- The instalation process informs me of a required access to the fone book. nothing more.
- As soon as it reaches the next step, Android advises me that the package is corrupted and instal cannot continue. :?

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4622
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Minimum Android Version is not selectable on Pref.

Post by jacque » Sun Jan 21, 2018 5:26 am

I had a similar problem with the Android installer using LC 9dp11 but when I tried it a second time it worked. You could try a rebuild. The LC team could not reproduce the issue and we closed the bug report. I did not get a corruption message, the installer just hung.

Did you select the right permissions in Android standalone settings? Also make sure you have added all required inclusions manually, don't rely on the automatic search for inclusions. It doesn't always find everything.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

teriibi
Posts: 254
Joined: Mon Nov 13, 2017 3:49 pm
Location: Bolivia

Re: Minimum Android Version is not selectable on Pref.

Post by teriibi » Sun Jan 21, 2018 11:02 pm

Tried again with the 9.11..and corrupted again - i ll try more times... :roll:

Oops, nop,
I ve let everythin in AUTO mode coz I m too good at screewing things by myself.

About Inclusions : I did not include any plugin or extention, just using plain LC functions, how do I make sure I m
not forgetting any needed filews : If I have imported some png as controls .. should I point to them somewhere here ?

How do one knows a particular inclusion is needed ?

No, have no idea about which right I should specify... you mean "Profile" right ?
Other or Master ?

Tkx.

teriibi
Posts: 254
Joined: Mon Nov 13, 2017 3:49 pm
Location: Bolivia

Re: Minimum Android Version is not selectable on Pref.

Post by teriibi » Sun Jan 21, 2018 11:08 pm

Tried again with the 9.11..and corrupted again - i ll try more times... :roll:

Oops, nop,
I ve let everythin in AUTO mode coz I m too good at screewing things by myself.

About Inclusions : I did not include any plugin or extention, just using plain LC functions, how do I make sure I m
not forgetting any needed filews : If I have imported some png as controls .. should I point to them somewhere here ?

How do one knows a particular inclusion is needed ?

No, have no idea about which right I should specify.
Do you mean which "Profile" = Other or Master ?
Or Which permission, i m going to select none, or just internet to make things simple at first.

Image

Tkx
Attachments
App permissions.png

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4622
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Minimum Android Version is not selectable on Pref.

Post by jacque » Sun Jan 21, 2018 11:45 pm

I see. Did you create a signing key? If so it's probably incorrect in some way. If not, that's probably the corruption. Choose "sign for development only" in the Android settings for now. If you decide to release on the Play Store you'll need a verified developer key later.

Does your app need access to the phone book /contacts? If so then you need to choose those permissions too. Keep the Internet permission as you have in the screen shot.

In the Inclusions pane choose the Internet library. If you are using LC Indy or another paid version then also include TSNet.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

teriibi
Posts: 254
Joined: Mon Nov 13, 2017 3:49 pm
Location: Bolivia

Re: Minimum Android Version is not selectable on Pref.

Post by teriibi » Mon Jan 22, 2018 1:08 am

nooooooo..no signing key ata ll,is it needed even for testing purpose ?
What if I don t want to put it on the playstore, would I stiil need to crete one ?

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4622
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Minimum Android Version is not selectable on Pref.

Post by jacque » Mon Jan 22, 2018 1:49 am

You don't need a signing key if you aren't going through the Play Store, though if you do distribute your work it helps to identify you as the developer. But it isn't required.

For APKs without a signing key just choose to sign for development only, and LC will create a generic key instead.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

teriibi
Posts: 254
Joined: Mon Nov 13, 2017 3:49 pm
Location: Bolivia

Re: Minimum Android Version is not selectable on Pref.

Post by teriibi » Mon Jan 22, 2018 2:39 am

Ok, I think I could find a way to go arround my false corrupted warning by "Signing for Dev only" !
Tks jacque, you ve helped pointing me to a solution !

Only problem now the final Stacks layout looks terribly ugly !!! :P :P :P
But..hey... its working fine at least ! :mrgreen:

Post Reply

Return to “Android Deployment”