Blistering fast x86 System Image....but

The place to discuss anything and everything about running your LiveCode on Android

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
sphere
Posts: 662
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Blistering fast x86 System Image....but

Post by sphere » Sat Dec 16, 2017 8:31 pm

Hi everyone,

i'm installing all on a new pc and also thought let's give Andriod Studio 3 a try instead of only the older sdk package.
So downloaded version 3 and installed it, then added the sdk packages (and forgot all about ARM eubi...), then created AVD with an x86 System Image with virtual blabla support (had to turn it on in the bios).
And like Google promised the emulator starts and works Blistering Fast!
So let's test an app, load a project into LC and hit the TEST button...wait...wait...wait...LC hangs...
Ok retry, close LC and restart it, hit test again, now i got this message:
error.PNG
error.PNG (4.5 KiB) Viewed 360 times
ok the apk was somewhere in appdata/temp, removed it
Let's check the old pc,mmmm i used an ARM image, oh yeah i totally forgot....
So on the new pc i made a new AVD with an ARM system image, started all again....wait....wait....wait...oh the emulator starts working
then start LC and hit the TEST button, takes a w..h..i..l..e but it all works.

So i forgot LC does not support x86 System images, but only the terrible slow ARM images......

When i'm correct with the above: then when will LC start supporting the Blistering Fast x86 System Images?
instead of the very very slow ARM images
Don't forget the Canary version's Emulator will be more faster, but x86 has to be supported as far as i did see.

Thanks!
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

Post Reply

Return to “Android Deployment”