Page 1 of 1

Can no longer build standalone with LC 6.6.5 [SOLVED]

Posted: Sat Mar 26, 2016 12:29 pm
by pkocsis
I need to build an android app with LC 6.6.5 due to bug I have encountered with the 6.7 series. I have not filed a report yet as I'm still trying to gather more info. The short of it is, mobilePickPhoto "camera" only works about 1 out of 20 attempts on, specifically, an HTC A9 with android 6.0.

I believe if I can recompile my app under 6.6.5 (which would use the android api 8 (version 2.2)), I can get the HTC A9's working while I track down the bug further.

The problem is that I can no longer create a standalone with 6.6.5. Even uninstalling the android sdk and reinstalling it with only api 8 results in the standalone builder finishing within 2 seconds and nothing appears in the created output folder.

Does anyone know specifically what version of "Android SDK Tools", "Android SDK Platform-tools", and "Android SDK Build-tools" I need or don't need in order to be able to build with LC 6.6.5 again?


Re: Can no longer build standalone with LC 6.6.5 [SOLVED]

Posted: Sun Mar 27, 2016 10:49 am
by pkocsis
The problem seems to have been that the stack that I was trying to build for android had both "build for iOS" and "build for android" checked. Of course, on Windows one cannot uncheck "build for iOS" in the standalone settings. Once I opened the stack on OSX and unchecked "build for iOS", and then re-opened in Windows, I could build for android. The strange thing is that it seems to me that I've been working with a stack that has had both checked for quite some time....seemingly even back when 6.6.5 was current. I could be wrong on that though......and 'yes' I have seen that discussed and I think addressed In the bug database.