Common Android Deployment issues

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

sphere
Posts: 801
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth

Re: Common Android Deployment issues

Post by sphere » Sun Feb 10, 2019 7:36 pm

The ARM is still useless slow. So when the 901DP1 will be ready it will support the x86. Then you can use the x86 Android emulator which is really fast.
Meep Meep....pyaaaaauuung :mrgreen:
2018 Worldwide Mobile Market share: Android 84.4% !!!, iOs 15.1%, others 0.1%

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4945
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Common Android Deployment issues

Post by jacque » Sun Feb 10, 2019 7:46 pm

That's good news. (You mean 9.0.2, right?) Then I can test on devices I don't own. Yay!
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

sphere
Posts: 801
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth

Re: Common Android Deployment issues

Post by sphere » Sun Feb 10, 2019 8:03 pm

No sorry 9.1.0DP1--i mixed up the 1 and 0 https://github.com/livecode/livecode-ide/milestone/97 seems almost ready
2018 Worldwide Mobile Market share: Android 84.4% !!!, iOs 15.1%, others 0.1%

thatkeith
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 242
Joined: Mon Mar 01, 2010 7:13 pm
Location: London, UK

Re: Common Android Deployment issues

Post by thatkeith » Fri Feb 15, 2019 8:18 pm

I'm new to Android development but not new to LiveCode. I am absolutely stumped (and rather annoyed) by how difficult it is to set up the Android SDK and get LiveCode to recognise it. Basically, I have utterly failed to do it.

I have a support contract so I can get help, which I will do if I must – but it's Friday evening now so I presume that help wouldn't be available for a while. Anyway, I just want to find some instructions that are simple, clear and up-to-date! Does this exist?

LiveCode 9.0.2
Mac OS X 10.14 (Mojave)

k
Senior Lecturer, LCC (University of the Arts London)
Technical Editor, MacUser (1996-2015)
President, IVRPA.org

simon.schvartzman
Posts: 274
Joined: Tue Jul 29, 2014 12:52 am
Location: Brazil

Re: Common Android Deployment issues

Post by simon.schvartzman » Fri Feb 15, 2019 8:30 pm

Sorry
I just want to find some instructions that are simple, clear and up-to-date! Does this exist?
I never found such a jewel. If you do please share...
Simon
________________________________________
To ";" or not to ";" that is the question

thatkeith
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 242
Joined: Mon Mar 01, 2010 7:13 pm
Location: London, UK

Re: Common Android Deployment issues

Post by thatkeith » Fri Feb 15, 2019 9:20 pm

Now I feel like I'm being trolled. In the https://livecode.com/resources/support/ page, down in the Setup section, there are four items: Download LiveCode, Activating LiveCode, iOS Setup, and Android Setup. Each has its own button designed, I presume, to take the user to the appropriate part of the site. Except...
The buttons for Activating LiveCode, iOS Setup, and Android Setup all point to https://livecode.com/download – which is where I can see my current LC licenses and download installers. It is NOT where any of the promised instructions are. I don't even know if those destinations even exist! :? :cry:
Senior Lecturer, LCC (University of the Arts London)
Technical Editor, MacUser (1996-2015)
President, IVRPA.org

Klaus
Posts: 10921
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: Common Android Deployment issues

Post by Klaus » Fri Feb 15, 2019 9:27 pm

Hi Keith,

maybe you mean these pages http://lessons.livecode.com/m/4069?

Best

Klaus

thatkeith
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 242
Joined: Mon Mar 01, 2010 7:13 pm
Location: London, UK

Re: Common Android Deployment issues

Post by thatkeith » Fri Feb 15, 2019 10:18 pm

THANK YOU Klaus! :!:
That page did help me get everything set up. I am deeply grateful.

Right, time for me to try Android! :D

EDIT: I spoke too soon:
"There was an error while saving the standalone application
could not compile service support class"
Image
:oops:
Senior Lecturer, LCC (University of the Arts London)
Technical Editor, MacUser (1996-2015)
President, IVRPA.org

Klaus
Posts: 10921
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: Common Android Deployment issues

Post by Klaus » Fri Feb 15, 2019 10:40 pm

I don't develop for mobile, don't even own any cellphone or tablet, but maybe this helps:
search.php?keywords=could+not+compile+s ... port+class :D

thatkeith
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 242
Joined: Mon Mar 01, 2010 7:13 pm
Location: London, UK

Re: Common Android Deployment issues

Post by thatkeith » Fri Feb 15, 2019 11:14 pm

It helped very much, thanks.

The problem turned out to be what someone else in one of those threads experienced: an incomplete removal of a newer Java install in /Library/Java/JavaVirtualMachines. LiveCode's automatic finding of the JDK path had picked up the newer one. Once I deleted that and re-picked the Android SDK the JDK path was remade to the correct one.

Phew! I've now built a test .apk successfully. I am DEEPLY grateful Klaus, and I hope others find it helpful too.

k
Senior Lecturer, LCC (University of the Arts London)
Technical Editor, MacUser (1996-2015)
President, IVRPA.org

simon.schvartzman
Posts: 274
Joined: Tue Jul 29, 2014 12:52 am
Location: Brazil

Re: Common Android Deployment issues

Post by simon.schvartzman » Sun Feb 17, 2019 1:18 pm

Hi Keith I want to apologize if it was my answer that made you "feel being trolled".

My answer was a consequence of my frustration with the lack of good documentation regarding Android installation. It took me several interactions (and I don't know how to reproduce the path) to get it working, as a matter of fact I still can't test on the Android simulators, just on real devices.

Regards
Simon
________________________________________
To ";" or not to ";" that is the question

bogs
Posts: 3287
Joined: Sat Feb 25, 2017 10:45 pm

Re: Common Android Deployment issues

Post by bogs » Sun Feb 17, 2019 1:33 pm

simon.schvartzman wrote:
Sun Feb 17, 2019 1:18 pm
Hi Keith I want to apologize if it was my answer that made you "feel being trolled".
I don't think he was referring to your answer Simon. From his post, I think he feels the 'trolling' is due to the way the various links he lists all point to the same page, which wasn't helpful (modified quote from Keith) :wink:
thatkeith wrote:
Fri Feb 15, 2019 9:20 pm
Now I feel like I'm being trolled. In the https://livecode.com/resources/support/ page, down in the Setup section, there are four items: Download LiveCode, Activating LiveCode, iOS Setup, and Android Setup. Each has its own button designed, I presume, to take the user to the appropriate part of the site. Except...
The buttons for Activating LiveCode, iOS Setup, and Android Setup all point to https://livecode.com/download
Image

thatkeith
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 242
Joined: Mon Mar 01, 2010 7:13 pm
Location: London, UK

Re: Common Android Deployment issues

Post by thatkeith » Tue Feb 26, 2019 3:20 pm

simon.schvartzman wrote:
Sun Feb 17, 2019 1:18 pm
Hi Keith I want to apologize if it was my answer that made you "feel being trolled".
bogs wrote:
Sun Feb 17, 2019 1:33 pm
I don't think he was referring to your answer Simon.
Absolutely right Bogs! :)
Simon, it was purely the frustrating experience of having paths consistently lead me to dead ends that felt like trolling, not your input at all.
I'm delighted to see the incorrect links have been fixed. Thank you to whoever implemented that. :)
Senior Lecturer, LCC (University of the Arts London)
Technical Editor, MacUser (1996-2015)
President, IVRPA.org

bogs
Posts: 3287
Joined: Sat Feb 25, 2017 10:45 pm

Re: Common Android Deployment issues

Post by bogs » Tue Feb 26, 2019 3:38 pm

thatkeith wrote:
Tue Feb 26, 2019 3:20 pm
I'm delighted to see the incorrect links have been fixed. Thank you to whoever implemented that. :)
I just love happy endings Image
Image

Post Reply

Return to “Android Deployment”