Can't Build Standalone

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
trags3
Posts: 296
Joined: Wed Apr 09, 2014 1:58 am
Location: Las Vegas, NV

Can't Build Standalone

Post by trags3 » Sat Aug 02, 2014 8:37 pm

From sometime in April until sometime in May I was working on an app on a windows 7 computer. I had set up the Android SDK and Java stuff and could build the apk file and install it on my Android phone. The simulator sort of worked but I found it much easier to test on the phone. The last time I built the standalone app for Android was May 24th.
At that point I set up everything on a MacBook pro and started working with the ios and testing the app on my iPhone as well as the simulator (which worked much better than the Android simulator). Now that I have the app pretty much worked out I have tried to build it for android. I never got the android stuff to work on the Mac so I tried the windows 7 machine.
When I "Save as Standalone Application" everything looks like it works (except I am not asked for my key chain password). I get no errors and it finishes in about a second with the message " Stand alone app saved successfully". No .apk file can be found anywhere.
Did something happen between May 24 and now?

Tom

pkocsis
Posts: 104
Joined: Sat Apr 15, 2006 7:20 am

Re: Can't Build Standalone

Post by pkocsis » Sun Aug 03, 2014 5:06 am

By chance did you happen to update your android sdk to r23 on your win7 machine? If so, see this thread:

http://forums.livecode.com/viewtopic.php?f=53&t=20966

In any case, have you rechecked your "mobile preferences" on your win7 machine to ensure that the android settings are still there?

trags3
Posts: 296
Joined: Wed Apr 09, 2014 1:58 am
Location: Las Vegas, NV

Re: Can't Build Standalone

Post by trags3 » Sun Aug 03, 2014 11:25 pm

pkocsis wrote:By chance did you happen to update your android sdk to r23 on your win7 machine?
I had the problem before I updated to r23. I updated and have put the zipalign file into the tools directory.
I still get the "not a valid SDK folder" message. Both on my windows 7 machine and my mac book pro.

I am at a loss. should I go back to an older version of LC? I am using 6.6.1 on both computers.

Tom

trags3
Posts: 296
Joined: Wed Apr 09, 2014 1:58 am
Location: Las Vegas, NV

Re: Can't Build Standalone

Post by trags3 » Mon Aug 04, 2014 10:51 am

rI completely reinstalled JDK and SDK's . I put the zipfile utility into the tools directory and now I no longer get the "Not a valid android SDK folder" message.
I can test the app on the Android emulator but when I connect the phone to the computer it does not show up in the test platform list. Also when I build for standalone I get no error messages, the process takes less than a second and I get the message "Standalone application saved successfully". The directory where the standalone is to be stored contains a new empty folder with no .apk file.
Making progress but I don't know where to go from here. I am using LC version 6.6.1. which before May 24 all was working fine. I am going to try to reinstall LiveCode as that is the only thing I haven't reinstalled.
Any other ideas would be appreciated.
Tom

trags3
Posts: 296
Joined: Wed Apr 09, 2014 1:58 am
Location: Las Vegas, NV

Re: Can't Build Standalone

Post by trags3 » Mon Aug 04, 2014 3:08 pm

trags3 wrote: I am going to try to reinstall LiveCode as that is the only thing I haven't reinstalled.
Any other ideas would be appreciated.
Tom
I updated to LC 6.7 dp 7 and everything seems to work fine now. :D 8)


Tom

Post Reply

Return to “Android Deployment”