Warning: 64-bit requirement [Solved]

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
Jellobus
Posts: 257
Joined: Tue Dec 10, 2013 2:53 pm

Warning: 64-bit requirement [Solved]

Post by Jellobus » Mon May 20, 2019 11:09 pm

Hello,

I got the warning message when I uploaded test app. I says " This release is not compliant with the Google Play 64-bit requirement.~"
I have used LC 9.0.4 (stable) on PC. How can I fix this issue?

Cheers,

Louis
Attachments
Screen Shot 2019-05-20 at 5.55.09 PM.png
warning sign
Last edited by Jellobus on Tue May 21, 2019 4:09 pm, edited 1 time in total.

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6633
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Warning: 64-bit requirement

Post by FourthWorld » Tue May 21, 2019 1:57 am

The new v9.5rc1 addresses this - from the Release Notes:
New Android Architectures
Android builds now support four architectures. Previously android was built for armv6 only.
Android is now built for armv7 , arm64 , x86 and x86_64 .
Checkboxes are included on in the Android standalone settings to choose which architectures to
include in the build. When deploying your application via the Test button to a device the device
architecture will be detected and used even if not chosen in standalone settings.
You can download it here:
https://downloads.livecode.com/livecode/
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Jellobus
Posts: 257
Joined: Tue Dec 10, 2013 2:53 pm

Re: Warning: 64-bit requirement

Post by Jellobus » Tue May 21, 2019 4:08 pm

Great. Thanks a lot!

Post Reply

Return to “Android Deployment”