Scrollbars Not Showing Up

This is a forum focused on providing support for rTree

Moderators: heatherlaine, robinmiller, kevinmiller, wilstrand

Post Reply
xclntdesign
Posts: 34
Joined: Sun Feb 06, 2011 8:33 pm

Scrollbars Not Showing Up

Post by xclntdesign » Fri Jul 15, 2011 2:59 pm

I have created an rTree in a new substack. I have set the scrollbars to both horizontal and vertical, large size and saved the stack.

When I click a button on my main stack to show the substack (first I tried modal, then toplevel, and neither made a difference), the rTree shows up without the scroll bars. If I expand one of the nodes, the scrollbars show up.

I tried adding the "set the autoScrollbar of control" command before the substack is opened, and that had no effect either.

I have another rTree in my main stack with the exact same data and setup, and the scrollbars work fine on that one.

Obviously I'm doing something wrong, but I can't figure out what it is for the life of me. Any help I can get would be great appreciated.

wilstrand
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 114
Joined: Mon Jan 03, 2011 3:02 pm
Contact:

Re: Scrollbars Not Showing Up

Post by wilstrand » Fri Jul 15, 2011 4:32 pm

Hi xcIntdesign!

If you have the autoScrollbar property of the tree set to true it means that the scrollbars only shows if the visible nodes are taking up more space than is available in the control. Maybe this is why they show when you expand the node?

To have the scrollbars always show, set the autoScrollbar property of the tree to false and check the hScrollbar and vScrollbar in the Property Inspector accordingly.

Please let me know if this solves your problem!

With my best regards
Mats
http:www.tapirsoft.on-rev.com
Open Source LiveCode Plugins - rIDE, rGrid, rTree
LiveCode projects

xclntdesign
Posts: 34
Joined: Sun Feb 06, 2011 8:33 pm

Re: Scrollbars Not Showing Up

Post by xclntdesign » Fri Jul 15, 2011 5:10 pm

That seems to have done the trick. Thanks!

Mag
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 802
Joined: Fri Nov 16, 2012 10:51 pm

Re: Scrollbars Not Showing Up

Post by Mag » Thu Feb 28, 2013 4:31 pm

Hi, is the autoScrollbar property something that I can set also for standard fields? I can't find it in the inspector palette...

Post Reply

Return to “rTree”