firstIconCollapsed lost in standalone, unsettable in IDE

This is a forum focused on providing support for rTree

Moderators: heatherlaine, robinmiller, kevinmiller, wilstrand

Post Reply
jameshale
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 284
Joined: Thu Sep 04, 2008 6:23 am
Location: Melbourne Australia

firstIconCollapsed lost in standalone, unsettable in IDE

Post by jameshale » Thu Apr 17, 2014 8:42 am

Description: in the IDE I set the firstIconCollapsed of the tree to the ID of an image (closed book)
--
set the firstIconCollapsed of group "TOCNavigation" card "Table of Contents" to 1060 # closed arrow
--
However, in the IDE the firstIconCollapsed appears as a triangle (triangle2.gif I think, not my open book)
In my standalone the firstIconCollapsed doesn't appear at all!
1. How do I actually set the firstIconCollapsed?
2. How can I get it to appear in my standalone?

Note: the firstIconExapanded works fine (in my case an open book)
also the secondIconCollapsed also works fine (a page icon)
It is only the first IconCollapsed that doesn't play ball.

(also submitted as an issue on tapirsoft)

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: firstIconCollapsed lost in standalone, unsettable in IDE

Post by malte » Mon Apr 21, 2014 4:34 pm

Hi James,

if you use your own icon images, it is a good idea to set the images ID first, in order to avoid conflicts with image IDs that are already in use by other stacks, like the one you are seeing now. To do that, either use the inspector, or the message box.

set the ID of image "myImage" to 444001

That number is high enough to avoid conflicts with already existing images. In rTree then use the new ID to make it work.

Hope that helps,

Malte

jameshale
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 284
Joined: Thu Sep 04, 2008 6:23 am
Location: Melbourne Australia

Re: firstIconCollapsed lost in standalone, unsettable in IDE

Post by jameshale » Tue Apr 22, 2014 5:41 am

thanks for that.
took a while as it seems I was setting the icons in two places and was only modifying one.
all fixed now.

BTW What are the constraints in the icons.
Size wise, how big can they be?

Klaus
Posts: 10409
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: firstIconCollapsed lost in standalone, unsettable in IDE

Post by Klaus » Tue Apr 22, 2014 12:35 pm

Hi James,
jameshale wrote:BTW What are the constraints in the icons.
Size wise, how big can they be?
since "icons" in LC are just the IDs of images, only the limits for images apply here.
And that is: The sky erm... RAM is the limit :D


Best

Klaus

jameshale
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 284
Joined: Thu Sep 04, 2008 6:23 am
Location: Melbourne Australia

Re: firstIconCollapsed lost in standalone, unsettable in IDE

Post by jameshale » Thu Apr 24, 2014 4:20 am

@klaus, yes for LC there are no limits as such.
But for rTree there are.
It appears the space available for any of the icons is determined by the textsize (more correctly the lineheight I guess) of a node.
there is a textsize node property which i have yet to get working but there also doesn't seem to be a single setting for the textsize/lineheight of the tree.

So my question remains, what are the limits for the icon sizes and in addition, how does one modify them for the whole tree?

Post Reply

Return to “rTree”