Page 1 of 1

[SOLVED] Is Community Plus win 9.0.2 slow ?

Posted: Tue Dec 11, 2018 9:27 pm
by samuel.vannesteBUSGvXT
Hello,
I installed LC Community Plus 9.0.2 32 bits on a new PC, Windows 10 Pro 64 bits. Quadcore processor, CPU Pentium N4200, 16 GB RAM, SSD.

After some minutes of coding, the IDE slows down for me. I have tried with Script Debug Mode enabled and disabled and it did the same.
The feeling is like if I was running and someone pulls me from the back. Writing is difficult because after some time I don't see the letters typed, only full sentences.

Please do you experience such troubles ? Many thanks

Re: Is Community Plus win 9.0.2 slow ?

Posted: Tue Dec 11, 2018 10:41 pm
by FourthWorld
I have heard some of this may related to timers in the IDE. Please run this in the Message Box next time it slows down, and post the output here:

Code: Select all

put the pendingMessages

Re: Is Community Plus win 9.0.2 slow ?

Posted: Tue Dec 11, 2018 11:00 pm
by samuel.vannesteBUSGvXT
Thanks a lot for the idea. Here is the output.

Some information could be missing because it took me some time to be able to type the command (I have tried 3/5 times). I will try to find a better way and will report if I can something better.

Code: Select all

1455,1544565572.37,revUpdateSelectionChanged,stack "C:/Users/svann/AppData/Roaming/RunRev/Components/LiveCode Community Plus 9.0.2/Toolset/libraries/revbackscriptlibrary.livecodescript"

Re: Is Community Plus win 9.0.2 slow ?

Posted: Tue Dec 11, 2018 11:05 pm
by FourthWorld
Thanks. A single entry doesn't seem very daunting at all, so I feel comfortable ruling out redundant timers for now.

Is the Project Browser open? If so, try closing it and seeing if that helps.

Poking around the bug database to see if related issues have been reported, I searched there for "windows slow" and found quite a few hits. Check out the last comment on this report:
https://quality.livecode.com/show_bug.cgi?id=21604

Re: [SOLVED] Is Community Plus win 9.0.2 slow ?

Posted: Tue Dec 11, 2018 11:17 pm
by samuel.vannesteBUSGvXT
Thanks Richard. You found the reply : I have disabled Windows included real time protection (how does it translate ? Something like Windows Defender) and this solved immediately with some messages being released (for example the console windows I had tried to open while entering the command you had suggested).

So it is more on the antivirus used than on LC's part. Thanks a lot again.

Re: [SOLVED] Is Community Plus win 9.0.2 slow ?

Posted: Wed Dec 12, 2018 1:00 pm
by AndyP
Great Work.

Turning off Windows defender helped but still slow, however, I use Avast AV and Malwarebytes for anti-virus and malware detection, both live scanning. Temporarily switching off Avast has shown a great speed up with LiveCode 9.0.2 on Windows 10, so it seems that LiveCode is doing something that Some AVs see as a problem.

I'm going to set some Avast scanning exclusions to see if I cant (at least on my machines) pin down what Avast does not like and report back later.

Re: [SOLVED] Is Community Plus win 9.0.2 slow ?

Posted: Wed Dec 12, 2018 7:28 pm
by samuel.vannesteBUSGvXT
AndyP wrote:
Wed Dec 12, 2018 1:00 pm
I'm going to set some Avast scanning exclusions
Just a quick tip (no advertising), if you can't manage it to work. I have tried with McAfee Total Protection (a licence we already had) and it is greatly working. Perhaps for you too. The difference is the "Application optimization" the software does in real time : I can see 12 optimisations after only 10 mn of use.
Again, it was no advertising from my part.

Re: [SOLVED] Is Community Plus win 9.0.2 slow ?

Posted: Thu Dec 13, 2018 9:08 am
by AndyP
Follow up

I've set exclusions for the following folders in Avast and Malwarebytes, and this really helps.
Still not snappy but better.

C:\Users\UserName\AppData\Roaming\RunRev\*

C:\Users\UserName\AppData\Local\RunRev\*
C:\Users\UserName\AppData\Local\._LiveCode_\*

and my user plugins directory

Re: [SOLVED] Is Community Plus win 9.0.2 slow ?

Posted: Thu Jan 03, 2019 3:45 pm
by jsubiros
Totally agree, I have the same problem with community 9.0.2 under Windows 10 i5 machine.
My colleagues said me that under Mac all is ok (seems).
I Hope Kevin Miller and Co. repairs this asap. :?

Re: [SOLVED] Is Community Plus win 9.0.2 slow ?

Posted: Thu Jan 03, 2019 4:47 pm
by jsubiros
I reinstall a clean one, previous I did that, and now seems ok.
AndyP wrote:
Thu Dec 13, 2018 9:08 am
Follow up

I've set exclusions for the following folders in Avast and Malwarebytes, and this really helps.
Still not snappy but better.

C:\Users\UserName\AppData\Roaming\RunRev\*

C:\Users\UserName\AppData\Local\RunRev\*
C:\Users\UserName\AppData\Local\._LiveCode_\*

and my user plugins directory

Re: [SOLVED] Is Community Plus win 9.0.2 slow ?

Posted: Wed Jan 09, 2019 6:29 pm
by samuel.vannesteBUSGvXT
I am not far away from giving up with that version (probably). Now, I get repeating chars when the code editor "blocks". Typing "not an integer" becomes "annnn innnteeeeger"...

I wonder if opening a "ticket" could help because I am probably the only one experiencing such things…

Re: [SOLVED] Is Community Plus win 9.0.2 slow ?

Posted: Wed Jan 09, 2019 8:40 pm
by SparkOut
No you are not the only one. The problem is making a reproducible recipe. Some reports regarding antivirus exclusions have indicated improvement but please log or update any bug listings with your observations, which will help identify any more details.