Page 1 of 1

Remote debugger issue

Posted: Sat Oct 13, 2018 1:19 pm
by mvillion
I decided to try the remote debugger today.

I added the inclusion and placed a strategic breakpoint to test and then deployed the app to iOS via the TEST button.
The app deployed but the arrow colour did not change to green in the IDE as it should.
The code stopped at the breakpoint but I had no control.

To validate the test, I removed the breakpoint and TESTed again and all worked okay.
This is completely repeatable, switching in and out but no control offered.

Any ideas?


Re: Remote debugger issue

Posted: Sat Oct 13, 2018 7:41 pm
by jacque
You actually don't need to include the remote debugger if you're using the Test button, it happens automatically. It won't hurt, but remember to remove it from your app before the final build or it will remain in there after release. If you aren't using the Test button then you do need to include it if you want to debug a standalone that you launch when the device isn't cabled to the computer.

When the debugger opens you will be in the same environment as normal debugging on the desktop machine. You should be able to step through the code, see variable values, etc. I'm not sure which arrow you mean, but at the top left of the window you should see the normal icons for step over, step into, etc. If you want to abort, the blue box icon should also be there. All keyboard shortcuts should also work.

You can't change any code while in this mode but you should be able to set and remove red dot breakpoints. If you want to change the scripts you need to close the app on the device, close the debugging window, change the script, and retest. There is a bug where a changed script does not show up in the remote debug editor. Quitting the app and clearing it from memory on the device is supposed to clear out the cached copy but it doesn't always. Note there are two copies of the script when remote debugging - - the original and a cached copy created by the remote debugger. Make sure you are looking at the right one, which will have "remote" in the window title.

Do you see the normal debugging icons at the top of the window?

Re: Remote debugger issue

Posted: Sat Oct 13, 2018 8:52 pm
by mvillion
Thanks for the feedback. Duly noted about the inclusions.

I was referring to the play icon in the TEST button. The documentation said it should turn green to indicate the debugger has been enabled.

I placed a button on my card with a breakpoint in it and nothing happens when it is run on iOS. When run in the IDE it stops as expected. (For clarity, I am running the business edition).

So. My understanding was.
-Plug in device via lighting cable
-Insert breakpoint into the code.
-Debugger should work.

I am not seeing anything different in the IDE so in my mind it is not working. Not sure if my understanding of the debugger is wrong. - Happy to be wrong. 8-)

Re: Remote debugger issue

Posted: Sat Oct 13, 2018 11:57 pm
by jacque
I wonder if you're having the same problem I had in almost all versions of LC 8. The remote debugger simply wouldn't load. The mailing list had no suggestions. At some point in LC 9 it started working again. I did give OSX permission to allow internet access to LC 8 but it didn't help. You could try adding that to system settings though, maybe it will work for you. I can't remember exactly but I think the setting is in the Security pane. (Not at my Mac right now to check.)

Re: Remote debugger issue

Posted: Sun Oct 14, 2018 12:02 am
by mvillion

I run VERY aggressive protection from the internet including additional firewalls, little nitch, DNS Crypt etc
Is it that the communication is via the internet or LAN / WLAN (hinted at within your reply).

I assumed it would connect via the lighting cable else how else would it know where to connect to as there is no configuration pane that I have seen. The documentation is a little light on how to ensure a correct setup.

Are you aware of any useful documentation I can look at about the comms aspects?

Re: Remote debugger issue

Posted: Sun Oct 14, 2018 5:04 am
by jacque
I only know that it creates a socket between the LC copy on the computer and the standalone on the device. That enables it to communicate whether or not the device is cabled to the machine. It doesn't use the cable, presumably communication travels over the LAN.

I'm not sure whether the system setting blocks all connections or just remote ones. No one seemed to know why some versions let me use remote debugging and others didn't, so I assumed it was something in my particular setup. Others didn't seem to have the problem, and recently it suddenly came back for me too.

I'm not aware of any docs, I picked up what I know piecemeal. I do remember when I first installed LC 8, OSX asked if I wanted to allow LC to receive internet connections and I said no, thinking it was a session only request. I couldn't enable it again after that so I started exploring system settings.

Re: Remote debugger issue

Posted: Sun Oct 14, 2018 11:51 pm
by jameshale
There is some documentation in the dictionary (of lc 9.01).
Go to “Guides” and look towards the bottom of the list.
You will see a link to the “remote debugger” among the other extensios.