Trying to install IOS SDK

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
kaveh1000
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 337
Joined: Sun Dec 18, 2011 7:23 pm
Location: London
Contact:

Trying to install IOS SDK

Post by kaveh1000 » Tue Oct 02, 2018 6:42 pm

Hi folks

This should be simple. I am using
  • LiveCode Community 9.0.1
  • MacOS High Sierra 10.13.6
I want to install IOS SDK. I have downloaded Xcode 10.0 and it is in the Application folder. When I open LiveCode, go to Preferences > Mobile support, I cannot select the Xcode App. When I try to save standalone IOS, I get:

There was a error while saving the standalone application. In order to perform device builds, you must have the iOS SDK 11.4 configured. iOS 11.4 comes with Xcode 9.4.

What am I missing?
Kaveh

jekyllandhyde
Posts: 90
Joined: Thu Feb 14, 2013 7:17 pm

Re: Trying to install IOS SDK

Post by jekyllandhyde » Wed Oct 03, 2018 3:29 am

I think Xcode is only supported to 9.4 on Mac 10.13.2+ Remove Xcode 10 and try with Xcode 9.4.

https://downloads.livecode.com/livecode ... -9_0_1.pdf

kaveh1000
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 337
Joined: Sun Dec 18, 2011 7:23 pm
Location: London
Contact:

Re: Trying to install IOS SDK

Post by kaveh1000 » Wed Oct 03, 2018 4:11 pm

Thank you so much. That was the problem. Now installed.

My next problem is getting a free Apple Developer account. the developer site is only offering me paid. I have contacted Apple support.

Thanks again.
Kaveh

Post Reply

Return to “iOS Deployment”