Changes to uploading to Apple store

Getting into LiveCode for iOS? Ask your questions here.

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
mvillion
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 74
Joined: Sun Feb 24, 2013 12:29 pm

Changes to uploading to Apple store

Post by mvillion » Thu Apr 12, 2018 10:36 pm

Hi everyone

Over the last year or so I have been happily writing code and uploading my apps to the App store without issue.
A build, zipping the build and Application loader was a complete doddle and it just worked.

I have gone to upload a new build and something has changed. I now have to use a .ipa file
http://lessons.livecode.com/m/4069/l/33 ... -app-store

Ok. I now have to use a command line to compress what was a right click. No biggie. It would be nice if the build function did that for us but heyho.

But I now get an error message from app loader.
'You must supply a CFBundleIdentifier for this request.'
What I do not understand is I have not changed anything at my end. My new build was just a change to a text file which contains a little bit of data. No major rebuilds of code. Same version of LC etc.

I am not sure what I am missing here. I have checked the LC 'Standalone Application Settings' and they look completely identical. I did generate the required 1024 x 1024 icon.

I looked at the info.plist file and it has this in it (It has an entry for CFBundleIdentifier - The same one I have always used)
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundleDisplayName</key>
<string>ASIRTA Baseline</string>
<key>CFBundleName</key>
<string>ASIRTA Baseline</string>
<key>CFBundleExecutable</key>
<string>ASIRTA Baseline</string>
<key>CFBundleIdentifier</key>
<string>com.squidsecurity.baseline</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundlePackageType</key>
<string>APPL</string>
<key>CFBundleSignature</key>
<string>????</string>

On itunes connect the app as this as settings
Bundle ID
com.squidsecurity.baseline

This has got me stumped.. Any clues anyone?

---
Ok. In an attempt to address this.
I have updated LC to version 9.0
I have updated xcode to version 9.2
I have refreshed provisioning profiles in the preferences of Xcode
I have removed and readded the Mobile support for iOS in Xcode to rebind it to xcode 9.2 (keep the original name of X-code as xcode 9.3 has installed itself and that is not compatible with LC9.0

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 441
Joined: Fri Feb 06, 2015 4:03 pm

Re: Changes to uploading to Apple store

Post by LiveCode_Panos » Fri Apr 13, 2018 2:26 pm

Hi Matt,

The error probably means that something has gone wrong when packaging the .ipa file.

Please have a look at this bug report, the user had the same issue.

Best,
Panos
--

PS: Apple has changed the rules of App Store submission and they now *require* a .ipa file

mvillion
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 74
Joined: Sun Feb 24, 2013 12:29 pm

Re: Changes to uploading to Apple store

Post by mvillion » Fri Apr 13, 2018 2:37 pm

Right. I have the solution to my problem.

User error

My build created a folder called 'asirta Baseline'. This folder container the 'asirta.app'
I was running the command lines against the 'asirta.app' [container] rather than against the root folder 'asirta baseline'

The instructions located are here http://lessons.livecode.com/m/4069/l/33 ... -app-store

Desktop/myApp/myApp.app
2. Open a terminal and navigate to your Desktop folder by typing this:
cd ~/Desktop
3. From the terminal, rename the "myApp" folder to "Payload" by typing:
mv myApp Payload
5. From the terminal, zip the "Payload" folder and rename it to "application.ipa" by typing:
zip -r application.ipa Payload
6. Now you can use Application Loader to upload the "application.ipa" file.

I would add a note.
Make sure you are running the commands against the folder containing the application and not the application itself.

Post Reply

Return to “iOS Deployment”