Could not find plist template for device target

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
LiadTal6
Posts: 14
Joined: Sat Jul 25, 2015 5:26 pm

Could not find plist template for device target

Post by LiadTal6 » Fri Oct 06, 2017 4:25 pm

Hi everyone,

I'm trying to save my app for iOS in LC 8.1.6 and that's the message that I get:
There was an error while saving the standalone application
Could not find plist template for device target

I'm using Xcode 6.2 and I don't understand what I need to do.
I read this topic and it didn't help me:
viewtopic.php?f=49&t=28022

Someone can help me please?

Thanks.

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 1990
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: Could not find plist template for device target

Post by jmburnod » Fri Oct 06, 2017 4:45 pm

Hi,
I'm using Xcode 6.2 and I don't understand what I need to do.
I think you have to use xCode 8.3.3
Best regards
Jean-Marc

LiveCode_Panos
Posts: 304
Joined: Fri Feb 06, 2015 4:03 pm

Re: Could not find plist template for device target

Post by LiveCode_Panos » Fri Oct 06, 2017 8:00 pm

Hi all,

The version of Xcode used with 8.1.6 depends on the OSX version:

Xcode 4.6.x on MacOS X 10.7
Xcode 5.1.x on MacOS X 10.8
Xcode 6.2.x on MacOS X 10.9
Xcode 7.2.x on Mac OS X 10.10
Xcode 8.2.x on MacOS X 10.11
Xcode 8.3.x on MacOS 10.12+

BUT if you want to deploy to *device*, you need at least Xcode 7.2.x and OSX 10.10.

Best,
Panos
--

LiadTal6
Posts: 14
Joined: Sat Jul 25, 2015 5:26 pm

Re: Could not find plist template for device target

Post by LiadTal6 » Sat Oct 07, 2017 1:09 pm

Thank you so much! Now it's working! :D

Post Reply

Return to “iOS Deployment”