Printing PDF or IOS problem

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
Posts: 130
Joined: Thu Sep 19, 2013 10:08 am

Printing PDF or IOS problem

Post by istech » Thu Oct 05, 2017 6:26 pm

Hi all,

I wonder if anyone can help.

I have an issue where I need to print a card on a sub-stack. But every time I open the sub-stack to print the script stops. This happens only on IOS. On Windows, it works as expected. Am I doing something wrong possible bug? see script below.

Code: Select all

lock screen
   go to cd "card" of stack "substack"
   --stops working here
   --open printing
   answer "check working1" with "okay"
   open printing to pdf tPDFPath

   if the result is "Cancel" then
      ## The user has cancelled printing
      exit mouseup
      ## Print the card into the printable area
      --open cd "card" of stack "substack"
      answer "check working2" with "okay"
      print cd "card" of stack "substack" into 0,0,595,842
      close printing
      answer "check working 3" with "okay"
   end if
   go to stack "mainstack"
   unlock screen
   answer "working" with "okay"

I am using LC 8.1.6 and XCODE 8.2.1

If anyone can point me in the right direction that would be great.


Posts: 130
Joined: Thu Sep 19, 2013 10:08 am

Re: Printing PDF or IOS problem

Post by istech » Fri Oct 06, 2017 9:52 am

Hi all,

Well I have made some progress on this issue and I think it could be either a corrupt stack or a bug.

To test I put a button on my sub stack with "go to "mainstack" in the button and this worked. subsequently,

after the first button I put on the sub-stack worked the main script now works as expected and executing

as expected. Not sure what to think at this point. But will do some more testing and see where it goes. :|

Post Reply

Return to “iOS Deployment”