invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.3.3)

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
drkosta
Posts: 19
Joined: Wed May 22, 2013 8:40 pm
Location: Stuttgart / Germany
Contact:

invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.3.3)

Post by drkosta » Sun Aug 27, 2017 12:10 pm

Hi there,

last week I updated my app in the App Store without any issue.

Yesterday I add some code build an App and used application loader for upload. Everything was fine, but after some minutes I got a notification via eMail (and push win iTunes connect app) that the binary is broken (?!) I tried with higher iOS Versions as minimum requirement but this did not solve the problem.

This is the eMail from apple:
Dear developer,

We have discovered one or more issues with your recent delivery for "Appname". To process your delivery, the following issues must be corrected:

Invalid Binary - The app contains one or more corrupted binaries. Rebuild the app and resubmit.

Once these issues have been corrected, you can then redeliver the corrected binary.

Regards,

The App Store team

The app runs without any issues in the simulators and on iOS devices (uploaded via Airlaunch).

From last week till today nothing changed in my configuration (I think).

Any Idea? Suggestions? Somebody with same issue?

Thanks in advance

Kosta

LCMark
Livecode Staff Member
Livecode Staff Member
Posts: 944
Joined: Thu Apr 11, 2013 11:27 am

Re: invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.

Post by LCMark » Mon Aug 28, 2017 9:59 am

@Kosta: You are the third user we've had reporting such an issue, and we are currently looking into it. Currently, the only similar problem we've found online is https://helpx.adobe.com/digital-publish ... inary.html (which is Adobe related, however, Adobe tools do a similar thing to LiveCode in terms of building iOS apps, so it is quite possibly the same issue). If you could check your provisioning profile you are using for the settings suggested in that link (Deselect "Enable For iCloud", "Enable for Passes" and/or "Enable for Data Protection") and rebuild / reupload then that would be great.

drkosta
Posts: 19
Joined: Wed May 22, 2013 8:40 pm
Location: Stuttgart / Germany
Contact:

Re: invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.

Post by drkosta » Mon Aug 28, 2017 10:19 am

Hi Mark,

thanks for the reply. I checked my provisioning profile / app id identifier and it does not contain "iCloud, Passes, and data protection". It is deactivated. So this is not solving the issue for me :(

Crossing my fingers for a fast solution :wink:

LCMark
Livecode Staff Member
Livecode Staff Member
Posts: 944
Joined: Thu Apr 11, 2013 11:27 am

Re: invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.

Post by LCMark » Mon Aug 28, 2017 6:32 pm

@Kosta: We've been investigating this for much of the day - we think we may have found the issue and will be fixing asap.

LCMark
Livecode Staff Member
Livecode Staff Member
Posts: 944
Joined: Thu Apr 11, 2013 11:27 am

Re: invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.

Post by LCMark » Tue Aug 29, 2017 8:52 am

@Kosta: I've reported this as bug http://quality.livecode.com/show_bug.cgi?id=20308 - a fix is also pending review and inclusion.

drkosta
Posts: 19
Joined: Wed May 22, 2013 8:40 pm
Location: Stuttgart / Germany
Contact:

Re: invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.

Post by drkosta » Tue Aug 29, 2017 8:57 am

Great,

thanks a lot! Hopefully soon it will be fixed.

LiveCode_Panos
Posts: 306
Joined: Fri Feb 06, 2015 4:03 pm

Re: invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.

Post by LiveCode_Panos » Thu Aug 31, 2017 11:46 am

Hi all,

We have built a new version of LiveCode 8.1.6 that addresses this issue.

So if you have already installed the original LiveCode 8.1.6 and are affected by this issue, please visit now

http://downloads.livecode.com/livecode/

and download the latest 8.1.6 (STABLE), released on the 31st of August.

Best regards,
The LiveCode Team

drkosta
Posts: 19
Joined: Wed May 22, 2013 8:40 pm
Location: Stuttgart / Germany
Contact:

Re: invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.

Post by drkosta » Thu Aug 31, 2017 11:55 am

Great Job!

Downloaded LC, build App, uploaded in to AppStore and now waiting for review.

Everything is fine again :)

Thanks a lot to the team!

LCMark
Livecode Staff Member
Livecode Staff Member
Posts: 944
Joined: Thu Apr 11, 2013 11:27 am

Re: invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.

Post by LCMark » Thu Aug 31, 2017 3:59 pm

@DrKosta: Great! Glad you are back up and running with app submission again :)

mattyj2001
Posts: 3
Joined: Tue Apr 04, 2017 8:02 am

Re: invalid binary issue iTunes connect (LC 8.1.6 / Xcode 8.

Post by mattyj2001 » Sat Sep 09, 2017 7:24 am

Just want to chime in and say thanks so much for fixing this. I can confirm that I released an app a couple weeks ago with no problem but ran into this when trying to release a patch, and with the 8.1.6 update it's now pending approval.

I've been having a supremely irritating conversation with Apple Developer Support where they have insisted for two days that my version/build numbering was incorrect, as if I don't know how to count. It would be insulting if it wasn't so hilarious.

It would be nice if when they change their entrance criteria or verification method that they send a relevant error to us. I insisted over and over again that my numbering scheme was sound and I really just wanted to know what binary was corrupt and why, but they were never able to move on.

This is my first released app and I really hope iTunes Connect and their support crew isn't like this all the time. :)

Post Reply

Return to “iOS Deployment”