mergLA mergLAEvaluate failing

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

mergLA mergLAEvaluate failing

Postby quailcreek » Thu Jul 06, 2017 4:01 am

mergLA mergLAEvaluate

I’ve run into an inconsistency when using mergLA. I have a series of four apps that are very similar. I created one then used that app as a templet to make the other three.

The problem I’m having with mergLA is that some of the apps fail the touchID part without even displaying the touchID/Cancel popup. Here’s the screwy part. Some of the apps work fine until I reload one of the other apps in the aeries, then the new one works but the one that was working then fails in the same place.

I thought maybe because all of the apps had the same dataGrid substack, and I get the waring when opening more that one at a time in the IDE that the substacks are the same, So I rebuild the three that were made from the first one. A lot of work but I thought it would be worth it. Well… no joy. Same thing is still happening.

Here’s a simple scenerio:
App A
App B
App C
App D

Load them all onto my phone.
App A works
App B works
App C fails
App D works

Reload app C onto my phone after making some simple changes.
App A works
App B fails
App C Works
App D fails
Which ones work and which fail seems to be totally random.

This code is from the settings card. It allows the user to turn touchID on or off.
Code: Select all
on hiliteChanged
   if the environment is not "mobile" then exit hiliteChanged
   put the highLight of me into pHilited
   put "1" into SQLArray[1]
   put pHilited into SQLArray[2]
   get executeSQL("BEGIN")
   if it is not an integer then
      -- error handling code
      answer "An error occured BEGIN"
      exit hiliteChanged
   end if
   put "UPDATE FigurePrefs SET TouchResult = :2 WHERE PrefID = :1" into tSQLStatement
   revExecuteSQL the uDatabaseID of this stack, tSQLStatement, "SQLArray"
   if the result is not an integer then
      get executeSQL("ROLLBACK")
      -- error handling here
      answer "An error occured ROLLBACK"
      exit hiliteChanged
   end if
  get executeSQL("COMMIT")
   if the result is an integer then
      answer "Settings updated!"
      answer "There was an error saving the setting!"
   end if
end hiliteChanged

This code is in a button. If the tTouch value is "true" execute mergLAEvaluate. This code is identical for all four apps. The difference is in the scrollUp handler.
Code: Select all
on touchEnd theID
   local tTouch,tPerfID,thePrefsQuery
   if environment() is not "mobile" then exit touchEnd
   put "1" into tPerfID
   put "SELECT TouchResult FROM FigurePrefs WHERE PrefID =:1" into thePrefsQuery
   put revDataFromQuery(,, the uDatabaseID of this stack ,thePrefsQuery,"tPerfID") into tTouch
   put tTouch into fld "testValue"
   if tTouch = "true" then
      mergLAEvaluate "Please verify"
      if the result is not "success" then
         answer the result
         exit touchEnd
         scrollUp -- this is a handler that displays choices using mergPopSheet
      end if
   else -- if tTouch is not true
   end if
end touchEnd
MacBook Pro OS 10.12.5
Posts: 585
Joined: Sun Feb 04, 2007 11:01 pm
Location: McKenna, WA

Re: mergLA mergLAEvaluate failing

Postby quailcreek » Sun Jul 09, 2017 4:40 am

Is anybody else having this kind of problem? I tried creating the SAs using 8.5.1.rc3 but I'm getting the same result.
MacBook Pro OS 10.12.5
Posts: 585
Joined: Sun Feb 04, 2007 11:01 pm
Location: McKenna, WA

Return to iOS Deployment

Who is online

Users browsing this forum: No registered users and 1 guest