No code signature found

Getting into LiveCode for iOS? Ask your questions here.

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

No code signature found

Post by sphere » Tue Jul 04, 2017 2:11 pm

Hello,

i'm testing an app which works ok in the simulator but gets refused to be installed on real Iphone 5s device;
LC 8.1.5-rc2
Xcode 8.3.3
Macos 10.12.5
Ios on phone 10.3.2
Target iOs in project in xcode as in LC is 10.3 or higher
After creating standalone in LC i get the error that some PNGs are not found but these are not selected in standalone settings so that's strange.
I also get ._embedded.mobileprovisioning is not found

Then selecting the device in Xcode and selecting the standalone app via the + sign gives the error No code signature found.

All is set to automatic. App Identifier and bundle identifier are correct.

created new Provisioning Profile while device was attached, still no luck.
maybe some things changed with the update of Xcode?
any suggestion anyone? should i use an older version of LC? (did not try it yet on Mac)

Thanks for any help.
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 420
Joined: Fri Feb 06, 2015 4:03 pm

Re: No code signature found

Post by LiveCode_Panos » Tue Jul 04, 2017 2:28 pm

Hello Jerry,

Did you by any chance modify the standalone (i.e. the .app file) after the standalone was built? For example did you modify the yourApp.app/Contents/Info.plist file?

Best,
Panos
--

PS: I have exactly the same setup and I can successfully create iOS standalones

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: No code signature found

Post by sphere » Tue Jul 04, 2017 2:48 pm

Hi Panos,
you're quick :)

No i did not change anything. I only updated xcode to the latest version.

When creating the Standalone App in LC (now i tried also 8.1.4) it gives errors that it can't find the icons. But in the standalone settings there are none selected.

I tried a 'fresh' livecode file and selected again all carefully what i needed and checked withing Xcode so that it is correct.
When trying to install on real device same error No Code Signature found.
When checking Xcode Managed Profile (!) sign it says: app ID and bundle ID matches, Certificates: 2 included, also device: 1 included.

Tried also different Project Formats: Xcode 3.2-compatible and Xcode 8.0-compatible.

to be correct: LC creates the standalone, Xcode refuses to put it on the device.

all the same.

Regards,
Jerry
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 420
Joined: Fri Feb 06, 2015 4:03 pm

Re: No code signature found

Post by LiveCode_Panos » Tue Jul 04, 2017 5:01 pm

Hi Jerry,
When creating the Standalone App in LC (now i tried also 8.1.4) it gives errors that it can't find the icons. But in the standalone settings there are none selected.
to be correct: LC creates the standalone, Xcode refuses to put it on the device.
Ok, if the standalone is successfully created, then those are warnings, not errors. Moreover, since you can deploy in simulator but not on device, then the issue is probably in your provisioning profiles/certificates.

Can you attach a screenshot of the error msg you get from Xcode when you try to install your app in your device?

Best,
Panos
--

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: No code signature found

Post by sphere » Tue Jul 04, 2017 5:26 pm

Hi Panos,

yes i can upload a screenshot here tomorrow. I have the Macbook at my job, did not take it home.
But it's just one line in it: No Code Signature found.

So i will come back to this.
Thanks!
Jerry
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 420
Joined: Fri Feb 06, 2015 4:03 pm

Re: No code signature found

Post by LiveCode_Panos » Tue Jul 04, 2017 5:49 pm

Hi Jerry,

I have googled for this error and it seems it is indeed related to provisioning profiles/certificates. (It does not come from LiveCode).

What most people suggest to do in this case, which worked for them, is to:

1. Remove all provisioning profiles installed in this machine (Clear out ~/Library/MobileDevice/Provisioning Profiles)
2. Remove expired certificates from Keychain
3. Remove expired/invalid certificates and provisioning profiles from Apple Dev Centre
4. Download a valid provisioning profile from Apple Dev Centre, and double click on it (this will install this provisioning profile in ~/Library/MobileDevice/Provisioning Profiles/ and it will be selectable from LC standalone application settings for iOS
5. Try again to build a standalone

If this does not work, it might be worth creating a fresh certificate and provisioning profile, and try again using this one.

Best,
Panos
--

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: No code signature found

Post by sphere » Tue Jul 04, 2017 7:46 pm

Hi Panos,

yes thanks, i found similair things this afternoon before posting.
Some seem outdated, as far as i have seen you can not download it anymore from the dev centre. (i know it was possible before)
[strikethru]All is done within Xcode.[/strikethru]

But i can remove the certificate from the keychain although it is valid as i could see, and the folder you've mentioned.

I will check tomorrow if i can create a complete new profile and then try again.
A while ago i also did some testing with it and then it worked ok. So i'm not sure why it went wrong now, but best thing looks like beginning from scratch.

I will keep you posted.

Thanks!

Kind regards,
Jerry
Last edited by sphere on Tue Jul 04, 2017 8:57 pm, edited 2 times in total.
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: No code signature found

Post by sphere » Tue Jul 04, 2017 8:46 pm

ah yes also another thing i remember from last time i tested. Back then it was free of charge to create a dev certificate and test on a real device.
They changed it and you have to pay, even if you test it on your own device. So because i still have the certificate which is valid from before, i'm not going to delete it. But this is probably the case why it is not signing the code.
So maybe the certificate is not working anymore because Apple changed the way of working with test-signing.

That's why i love Android :) it's your phone, do what you like! That's why Android is the most used phone OS....ok back to were i was, I also have an iPhone from the job but i don't used it anymore because it's a drag, but.......my employer had an idea to create an app. So i'm busy with it, the demo runs ok on Android but of course they want to see a demo on iPhone before jumping completely into it and get a license for Indy Livecode and the Apple Dev.

But i will check if i can manage to get some further, but reading the help pages on Apple Dev, reminded me of this change they made a while ago.
Please correct me if i'm wrong.
Thanks.
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 420
Joined: Fri Feb 06, 2015 4:03 pm

Re: No code signature found

Post by LiveCode_Panos » Wed Jul 05, 2017 9:58 am

Hi Jerry,

You can still download a provisioning profile from the Apple Dev Center. Just click on the profile, and there is a "Download" button. at least this is the case if you have an active Apple dev subscription.

Now, regarding the free provisioning profile, you can still create one, and use it to test on your device, but I think it will be valid for only a week. Once it expires, you have to create a new one, following the same process. Moreover. I *think* that you cannot use some specific iOS features/capabilities (such as Push Notifications, In-App Purchase etc) when using a free iOS provisioning profile.

Here is a LC lesson on how to create and use a free iOS Development Provisioning Profile.

Best regards,
Panos
--

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: No code signature found

Post by sphere » Wed Jul 05, 2017 2:35 pm

Hi Panos,

this is the screenshot:
error.jpeg
I re-did the lessons to get a new Provisioning Profile.
This all seems not to work anymore unless you have like you said an active subscription. Too bad, right now i do not have that for Apple. So we are limited by the emulator now.

My certificates in the Keychain are still valid, everything matches. Except Xcode refuses to sign.

So for now i think we'll stick with the emulator.

THanks so far.

Best,
Jerry
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 420
Joined: Fri Feb 06, 2015 4:03 pm

Re: No code signature found

Post by LiveCode_Panos » Wed Jul 05, 2017 3:46 pm

Hi Jerry,

Have you followed this lesson? (sorry I forgot to post the link in my previous post):

https://livecode.com/how-to-create-a-fr ... g-profile/

This should not require an active dev subscription.

Best,
Panos
--

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: No code signature found

Post by sphere » Wed Jul 05, 2017 8:30 pm

Hi Panos,

i followed http://lessons.livecode.com/m/4069/l/42 ... ng-profile maybe there is a difference between the 2.

Tomorrow i can try this one to see what happens, it's not working now anyway.
Maybe Apple changed something again, why this maybe is not working anymore.

I'll keep you posted.

Thanks for your help.

***edit*** found some interesting via the reddit site which was mentioned by Neil in the comments on the blog you've mentioned. Maybe this can help if it will not succeed to get a working situation https://fastlane.tools/ it seems a free github project, especcially the docs page is helpful https://docs.fastlane.tools/codesigning/xcode-project/

***2nd edit*** found also some interesting info about Signing the code for others who are interested too, why and how this works, so have to do some reading to get more understanding.
https://www.objc.io/issues/17-security/ ... e-signing/
https://medium.com/ios-os-x-development ... b247760bef

Kind regards,
Jerry
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: No code signature found

Post by sphere » Thu Jul 06, 2017 8:52 am

Hi Panos,

i checked for the folder as mentioned above to remove Provisioning Profiles, (Via Terminal i can find it)

Did a test again following again the lesson. So deleted the project and created a new one in Xcode. Made sure identifiers are equal to the one in LC.
Made sure the device is set correct also, i read somewhere this is important too:
set the target real device.jpeg
Then pressed the PLAY button in Xcode, this will build it and install it on the phone. So after accepting the certificate in the phone, now i get the nice 3D Jetfighter Plane on the phone.
So this looks promising.
Then in LC i build the app and checked before if all settings were the same as in Xcode like iOs version and indentifier and selected the Provisioning Profile.
Then back to Xcode, selected the Device and it showed that the xcode build was installed, so it asked do you want to replace after selecting the LC build. But after confirming it refused again with Code Signing Error. So indeed the fault must lie with the Provisioning Profile. It seems LC can't find it correctly see the last line in the error after building in LC.
error build lc app.jpeg
To be continued...

Regards,
Jerry
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 420
Joined: Fri Feb 06, 2015 4:03 pm

Re: No code signature found

Post by LiveCode_Panos » Thu Jul 06, 2017 10:48 am

Hi Jerry,

I may be completely wrong, but I am wondering if the original Xcode build of the app was not completely deleted/cleared, and there are still some traces of this app (with this app identifier) in the device .

Can you build a different (i.e. using a different app identifier) app in LC and install it in your phone?

Best,
Panos
--

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: No code signature found

Post by sphere » Thu Jul 06, 2017 12:18 pm

Hi Panos,

i deleted the user account and added it again in Xcode.
Then created a new project in Xcode, Xcode started repairing some info.
Then i used a copy of the LC file and changed the names and identifiers according to the created xcode identifier.
Created standalone on LC and then tried to install it on the iPhone.

So all different but same issue remains.
test.jpeg
Kind regards,
Jerry
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

Post Reply

Return to “iOS Deployment”