Custom font not working in iOS 10.3?

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Custom font not working in iOS 10.3?

Postby ctflatt » Sat Apr 29, 2017 7:25 pm

I have noticed on 3 projects I am working on that custom fonts which previously worked (pre iOS 10.3) are not working. Can anyone verify this?

I am creating standalones with LC 9 dp 6, the same way I always have. While fontNames() returns the custom fonts as installed, they do not display properly.

Could someone check this to make sure it's not just me... it could be LC 9, but I'm not sure.

Any help would be MUCH appreciated.

Thank you!
ctflatt
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 240
Joined: Sun Dec 06, 2009 12:24 am
Location: Fredericktown, MO

Re: Custom font not working in iOS 10.3?

Postby LiveCode_Panos » Sun Apr 30, 2017 11:37 am

Hi ctflatt,

What you experience sounds like this bug: http://quality.livecode.com/show_bug.cgi?id=19358

If this is the case, it affects only LiveCode 9.0-DP-X, so LiveCode 8.1.3 should work as expected.

Best,
Panos
--

PS: What is the device(s) you are using?
LiveCode_Panos
 
Posts: 276
Joined: Fri Feb 06, 2015 4:03 pm

Re: Custom font not working in iOS 10.3?

Postby ctflatt » Sun Apr 30, 2017 2:07 pm

Panos,

Thank you for the pointing to the bug. I believe it is a 10.3.1 issue, as I did not experience this problem prior to the iOS upgrade a couple of weeks ago. Additionally, existing builds that were working built with LC9pd6 are crashing at startup. This leads me to believe it's an iOS update issue as originally mentioned in my post.

Note that I did list fonts with fontNames() and my included fonts are installed. However, the default font is used wherever the custom font has been specified by its listed name.

I am testing on physical devices iPad Mini and iPhone 6, both updated to 10.3.1.

I will try a build with LC8 and report back.

Thank you very much!
ctflatt
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 240
Joined: Sun Dec 06, 2009 12:24 am
Location: Fredericktown, MO

Re: Custom font not working in iOS 10.3?

Postby ctflatt » Sun Apr 30, 2017 6:08 pm

LC 8.1.4 rc 1 works!

Thanks for everything!

Christopher
ctflatt
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 240
Joined: Sun Dec 06, 2009 12:24 am
Location: Fredericktown, MO

Re: Custom font not working in iOS 10.3?

Postby LiveCode_Panos » Sun Apr 30, 2017 7:32 pm

Hi Christopher,

You are welcome. I will add a link to this discussion in this bug report. You can add your email in the cc list of the bug report to get notified when this bug is fixed in LC 9.0 - X.

Best,
Panos
--
LiveCode_Panos
 
Posts: 276
Joined: Fri Feb 06, 2015 4:03 pm

Re: Custom font not working in iOS 10.3?

Postby quailcreek » Thu Jun 29, 2017 1:11 am

Hi,
I'm having this problem too, on my iPhone 6s running iOS 10.3.2
I have three fonts added in copy files.
If I compile with LC 8 is see all the fonts.
With LC 9 DP 6 or 7... no fonts.
Tom
MacBook Pro OS 10.12.5
quailcreek
 
Posts: 586
Joined: Sun Feb 04, 2007 11:01 pm
Location: McKenna, WA


Return to iOS Deployment

Who is online

Users browsing this forum: No registered users and 3 guests