MergAV on LC 8.1.2 and Xcode 8.1 - ARM64 error

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
uncleb
Posts: 9
Joined: Fri May 20, 2016 4:16 pm

MergAV on LC 8.1.2 and Xcode 8.1 - ARM64 error

Post by uncleb » Fri Feb 03, 2017 3:32 pm

HI all,

I'm trying to build an iOS app using OSX 10.11.6, LC 8.1.2 Indy, Xcode 8.1 and the following externals:

- mergAV-4.0.22
- mergDropbox-1.0.34

It throws up an ARM64 error:
Screen Shot 2017-02-03 at 14.27.18.png
Screen Shot 2017-02-03 at 14.27.18.png (30.95 KiB) Viewed 2014 times
I'm not sure what else I can do to get this to work - does the latest MergExt not work with 8.1.2 and 8.1 Xcode? Any help gratefully received!

Thanks,
ian.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 672
Joined: Fri Feb 06, 2015 4:03 pm

Re: MergAV on LC 8.1.2 and Xcode 8.1 - ARM64 error

Post by LiveCode_Panos » Fri Feb 03, 2017 3:53 pm

Hi Ian,

I suggest you choose "Select Inclusions" in the "General" pane of the Standalone Application Settings, and then check "mergDropbox" and "mergAV" in the "Inclusions" pane. This should fix the error you are seeing.

Best,
Panos
--

uncleb
Posts: 9
Joined: Fri May 20, 2016 4:16 pm

Re: MergAV on LC 8.1.2 and Xcode 8.1 - ARM64 error

Post by uncleb » Fri Feb 03, 2017 4:17 pm

Panos, you're a legend! (And I've been using LiveCode on and off since about 2000 so I *really* should have worked that one out myself...)

Thanks,
ian.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 672
Joined: Fri Feb 06, 2015 4:03 pm

Re: MergAV on LC 8.1.2 and Xcode 8.1 - ARM64 error

Post by LiveCode_Panos » Fri Feb 03, 2017 4:21 pm

Hi Ian,

I am glad this fixed the problem for you. In LC 8.1.x, the mergExt externals are included in the LC app bundle. So you no longer need to use the "old way" of including those externals. They are available by default in the IDE, and you have to add them manually in the standalones, by just checking the ones you need in the "Inclusions" pane.

Best,
Panos
--

Post Reply

Return to “iOS Deployment”