Could not find plist template for device target

Getting into LiveCode for iOS? Ask your questions here.

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

djkesler
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 18
Joined: Tue Jun 01, 2010 10:37 pm

Could not find plist template for device target

Post by djkesler » Thu Sep 29, 2016 1:04 am

I receive the above error while trying to build an iOS standalone in Xcode 8 and LC 8.1.1 (rc1). I couldn't find a reference to a plist in the screens of the builder for iOS. Anyone seen an issue like this?

Thanks for any help.
David Kesler

djkesler
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 18
Joined: Tue Jun 01, 2010 10:37 pm

Re: Could not find plist template for device target

Post by djkesler » Thu Sep 29, 2016 1:27 am

I found the problem. I made iOS 9 the minimum version and set the 32 bit slice only on the iOS pane and it successfully built.

David Kesler

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: Could not find plist template for device target

Post by sphere » Fri Sep 30, 2016 11:12 am

Same here:
error lc811rc1.tiff
error LC8.1.1rc1.tiff
build for in lc8.1.1rc1.tiff
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: Could not find plist template for device target

Post by sphere » Fri Sep 30, 2016 11:15 am

and: (seems to only accepting 3 pictures)
settings in lc811rc1.tiff
Ios deployment target in xcode8.0.tiff
Ios deployment target in xcode8.0.tiff (10.29 KiB) Viewed 3011 times
error xcode missing file.tiff

So did you set the minimum to 9 only in LC or also in Xcode ?

This is with Xcode8.0 - LC 8.1.1rc1 and MacOs Sierra

Thanks
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: Could not find plist template for device target

Post by sphere » Fri Sep 30, 2016 11:18 am

It's already reported as a bug, but the solution in the report is not working.
http://quality.livecode.com/show_bug.cgi?id=11357 but this one is closed

check also this which is still open:
http://quality.livecode.com/show_bug.cgi?id=18507
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: Could not find plist template for device target

Post by sphere » Fri Sep 30, 2016 11:53 am

Choosing a lower iOS gives me this error:
choosing lower ios.tiff
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

dave.kilroy
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 856
Joined: Wed Jun 24, 2009 1:17 pm
Location: Plymouth, UK
Contact:

Re: Could not find plist template for device target

Post by dave.kilroy » Sun Oct 02, 2016 9:57 pm

Oops I think I should have posted in this thread instead of http://forums.livecode.com/viewtopic.ph ... 19#p146919

Anyway, try deleting your installation of LC 8.1.1(rc1) and reinstalling - worked for me...
"...this is not the code you are looking for..."

Scoperzor
Posts: 75
Joined: Tue Jan 27, 2015 1:10 pm

Re: Could not find plist template for device target

Post by Scoperzor » Mon Oct 03, 2016 7:24 am

I'm also getting this plist error on LC 8.1.1 (rc1) and using Xcode 8. I tried switching Xcode paths and reinstalling LC without success.

Image

If I try go back to LC 8.1.0 stable I just get this error:

Image

...despite the fact that you can clearly see I have those SDKs still in the default Xcode directory.

So basically now I can't go back to an older version of LC8, and I can't stick with the new one as Xcode 7 yields an ARM error and Xcode 8 yields this plist error.

Not sure what to do.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 420
Joined: Fri Feb 06, 2015 4:03 pm

Re: Could not find plist template for device target

Post by LiveCode_Panos » Mon Oct 03, 2016 10:31 am

Hi all,

Choosing 10.0 as minimum iOS version in the standalone settings will trigger a build error. This is a bug, see http://quality.livecode.com/show_bug.cgi?id=18507 for a workaround, as well as some notes to prevent build errors using Xcode 8.

Best,
Panos
--

Scoperzor
Posts: 75
Joined: Tue Jan 27, 2015 1:10 pm

Re: Could not find plist template for device target

Post by Scoperzor » Mon Oct 03, 2016 11:12 am

LiveCode_Panos wrote:Hi all,

Choosing 10.0 as minimum iOS version in the standalone settings will trigger a build error. This is a bug, see http://quality.livecode.com/show_bug.cgi?id=18507 for a workaround, as well as some notes to prevent build errors using Xcode 8.

Best,
Panos
--
Hi Panos

I read through your reply and that still does not address my specific issue. Specifically your quote here:

"3. If you are on 10.11.0 < OS X < 10.11.5, you will have to upgrade to 10.11.5 to use Xcode 8 in LC 8.1.1 RC-1"

I'm on 10.11.5 and use Xcode 8 and LC 8.1.1 RC1, but it still gives me the plist error. I have never set the minimum iOS version to 10, I normally use 9.3, but it doesn't work regardless of which one I select. Note I also reinstalled LC during this process to try rectify it, and did the process around switching Xcode paths.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 420
Joined: Fri Feb 06, 2015 4:03 pm

Re: Could not find plist template for device target

Post by LiveCode_Panos » Mon Oct 03, 2016 12:55 pm

Hi Scoperzor,

Thank you for the follow up. That's weird. I cannot reproduce this error. I suggest you file a bug report at quality.livecode.com so as we investigate this further. Since we cannot reproduce it, please make sure you attach the stack that produces this error (or send it to panos.merakos@livecode.com if it is confidential).

BTW could you please check if there is a file "Settings.plist" in LiveCode 8.1.1 (rc 1)/Contents/Tools/Runtime/iOS/Device-10_0/ ?

This error ("could not find plist template for .." ) is normally thrown if this file is missing.

Best,
Panos
--

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: Could not find plist template for device target

Post by sphere » Mon Oct 03, 2016 6:19 pm

sorry, doesn't work for me on Sierra which is MAcOS 10.12. & LC8.1.1rc1 & xcode 8.

Also not when setting the version to 9.3 in Livecode.

So avoiding the bug is not working for me.

Have to try the rework of the setting button script as mentioned in the bug report, will test tomorrow.
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: Could not find plist template for device target

Post by sphere » Tue Oct 04, 2016 7:13 am

Just tested it.

Setting the iOs version on 9.3 or lower gives this error:
lowerthan10afterscriptchange.tiff
But setting it to 10.0 works!
Thanks!

Kind regards,
Sphere
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

strongbow
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 118
Joined: Mon Jul 31, 2006 1:39 am
Location: New Zealand, Australia, Germany, Japan
Contact:

Re: Could not find plist template for device target

Post by strongbow » Fri Apr 21, 2017 4:51 am

I get this error when attempting to build with LC 8.1.3 for target iOS from 6-9 (that's all I've attempted so far). Am on OSX 10.9.5.

Any solutions to this generally? I used to be able to build successfully fine.

dave.kilroy
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 856
Joined: Wed Jun 24, 2009 1:17 pm
Location: Plymouth, UK
Contact:

Re: Could not find plist template for device target

Post by dave.kilroy » Fri Apr 21, 2017 8:39 am

hi @strongbow - if you're on OS X 10.9 it looks like you should be using Xcode 6.2 - the following is an extract from the Release Notes from LC 8.1.4(rc1)
iOS
iOS deployment is possible when running LiveCode IDE on a Mac, and provided Xcode is installed and has been set in LiveCode Preferences (in the Mobile Support pane).

Currently, the supported versions of Xcode are:
- Xcode 4.6 on MacOS X 10.7
- Xcode 5.1 on MacOS X 10.8
- Xcode 6.2 on MacOS X 10.9
- Xcode 6.2 and 7.2 on Mac OS X 10.10 Xcode 8.2 on MacOS X 10.11
- Xcode 8.2 on MacOS 10.12
"...this is not the code you are looking for..."

Post Reply

Return to “iOS Deployment”