Codesigning error

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

chelling
Posts: 95
Joined: Tue Mar 06, 2007 3:14 am

Codesigning error

Post by chelling » Wed Sep 21, 2016 5:35 pm

I am trying to updates apps that have been affected by the screen crop problem in iOS 10. I am using Mac OS 10.11.6, LiveCode 8.1 and Xcode 7.3.1. Once app uses MergDoc. I can’t get a successful build. I deleted mergDoc.lcext from the Copy Files pane. The most recent error begins “codesigning failed with Warning: --resource-rules has been deprecated in Mac OS X >= 10.10 iPhone Distribution….” I have deleted and reinstalled all profiles. The certificates are valid and installed in Keychain. In the Xcode 7 Apple ID details, the IOS signing identity has a “create” button. I have even tried to create one by clicking, but it just dims (like it is creating one) but doesn’t complete. Does anyone have any suggestions?

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 571
Joined: Fri Feb 06, 2015 4:03 pm

Re: Codesigning error

Post by LiveCode_Panos » Wed Sep 21, 2016 8:18 pm

Hi chelling,

What is the full error you get? The part "Warning: --resource-rules has been deprecated in Mac OS X >= 10.10" is harmless, and it is not the cause the build fails.

Best,
Panos
--

chelling
Posts: 95
Joined: Tue Mar 06, 2007 3:14 am

Re: Codesigning error

Post by chelling » Wed Sep 21, 2016 8:30 pm

codesigning failed with Warning: --resource-rules has been deprecated in Mac OS X >= 10.101 iPhone Distribution: Celeste He!ling (KFT2AG35CL): ambiguous (matches "iPhone Distribution: Celeste He!ling (KFT2AG3SCL)" and "iPhone Distribution: Celeste He!ling (KFT2AG35CL)" in /Users/chelling/Library/Keychains/login.keychain)

teacherguy
Posts: 373
Joined: Thu Dec 08, 2011 2:43 am

Re: Codesigning error

Post by teacherguy » Thu Sep 22, 2016 12:37 am

Are you using a beta of OS X Sierra?

chelling
Posts: 95
Joined: Tue Mar 06, 2007 3:14 am

Re: Codesigning error

Post by chelling » Thu Sep 22, 2016 12:59 am

No. I am using 10.11.6, El Capitan. I uninstalled all copies of Livecode and Xcode and reinstalled. I was finally able to complete a build with Xcode 7.3 without the mergDoc.lcext included in the Copy Files pane. I am rebuilding again with it included in the Copy Files pane. While I was writing this, it threw this error:

linking for arm (arm64) failed with Id: warning: object file
(/private/var/folders/7k/pxmfps75663d2714ppjlzjy8000Ogn/T/Temporaryltems/tmp.477.1Zi93JPS)
was built for newer iOS version (9.3) than being linked (7.1)
Id: warning: object file (/Applications/LiveCode Indy
8.1.0.app/Contents/Tools/Runtime/i0S/Device-9_3/Standalone) was built for newer iOS version
(9.3) than being linked (7.1)
Id: warning: object file (/Applications/LiveCode Indy
8.1.0.app/Contents/Tools/Runtime/i0S/Device-9_3/revpdfprinter) was built for newer iOS version
(9.3) than being linked (7.1)
Undefined symbols for architecture arm64:
" libinfoptr_mergDoc", referenced from:
-u command line option
Id: symbol(s) not found for architecture arm64
clang: error linker command failed with exit code 1 (use -v to see invocation)

Update: The successful build wouldn't install on the iPad. I got this message: A valid provisioning profile for this executable was not found.

teacherguy
Posts: 373
Joined: Thu Dec 08, 2011 2:43 am

Re: Codesigning error

Post by teacherguy » Thu Sep 22, 2016 1:18 am

For the >9.3 error you can change your build to only build for 9.3 or higher and that should take care of it.

As for the profile, you might want to log onto the developer.apple.com website and make sure that profile hasn't expired.

chelling
Posts: 95
Joined: Tue Mar 06, 2007 3:14 am

Re: Codesigning error

Post by chelling » Thu Sep 22, 2016 1:32 am

I thought about building for 9.3 so that is next on my iist. The profiles are all valid. This is frustrating! Thanks for your help.

chelling
Posts: 95
Joined: Tue Mar 06, 2007 3:14 am

Re: Codesigning error

Post by chelling » Fri Sep 23, 2016 3:58 am

This is where I am at with this... I can complete the build, and generally get it onto an iPad with iOS 10. When I try to upload the build via Application Loader, it is not successful due to missing profile. I have attached a screen shot comparison of Xcode 8 vs 7.3.1 prefs. Xcode 8 is fine, Xcode 7.3.1 will not load the iOS Development certificate. The profiles are all correctly set up. I am starting to think this is a Livecode and Xcode 8 issue - if version 8 was compatible, it would build fine. Any suggestions? This is keeping users from completing evaluations for clients. Thanks in advance.
Attachments
XcodePrefs.png

teacherguy
Posts: 373
Joined: Thu Dec 08, 2011 2:43 am

Re: Codesigning error

Post by teacherguy » Sat Sep 24, 2016 4:11 pm

Do you have a current/valid profile for that app for App Store distribution? Sometimes we forget that we need to change the profile from the one we are using for development/testing to the one for the App Store.

chelling
Posts: 95
Joined: Tue Mar 06, 2007 3:14 am

Re: Codesigning error

Post by chelling » Sat Sep 24, 2016 5:46 pm

Yes. Everything is valid and installed. Yesterday, I created a new wild card ID, associated it with the app ID, and uploaded it. There was an error that it was different from the original ID and may cause problems with keychain access. I went ahead and uploaded it, and am hoping for the best.

DRJ-UK
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 73
Joined: Tue Aug 23, 2011 2:50 pm
Location: United Kingdom
Contact:

Re: Codesigning error

Post by DRJ-UK » Sun Sep 25, 2016 4:31 pm

Colleagues

Seems that building iOS Apps with Livecode 8.1 on macOS Sierra is broken when getting to the code-signing section of the build process. All certificates and profiles are up-to-date so this is a real problem if you have upgraded macOS.

Points made by Chelling are valid.

We''ll just have to await a fix at some point in the future.
LiveCode: Versions 8.0, 8.1
Xcode: Version 7.3, 8.0
Mac OS X: 10.11.12 (macOS Sierra) on iMacs with 3.4 Intel Core i7 & 16GB Memory

Creating Apps for educational professionals, effective teaching and learning.

teacherguy
Posts: 373
Joined: Thu Dec 08, 2011 2:43 am

Re: Codesigning error

Post by teacherguy » Sun Sep 25, 2016 6:47 pm

On Sierra it's currently not working correctly using Xcode either...

peter-b
Posts: 182
Joined: Thu Nov 20, 2014 2:14 pm
Location: LiveCode Ltd.

Re: Codesigning error

Post by peter-b » Mon Sep 26, 2016 11:51 am

Did you update to 8.1.1-rc-1 yet? 8.1.1 has a large number of fixes related to codesigning for Xcode 8 and for Mac OS 10.12.

Please let me know if you're still experiencing issues when deploying with LiveCode 8.1.1.
LiveCode Open Source Team — @PeterTBBrett — peter.brett@livecode.com

ludo
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 66
Joined: Mon Dec 03, 2007 6:10 pm

Re: Codesigning error

Post by ludo » Wed Sep 28, 2016 8:32 am

I've got the same error.

In Xcode 8 preferences, "Locations", you need to set the command tools to xcode 8

Scoperzor
Posts: 78
Joined: Tue Jan 27, 2015 1:10 pm

Re: Codesigning error

Post by Scoperzor » Thu Oct 13, 2016 11:54 am

Is there any solution to this? Still getting same error with 8.1.1 rc2 on macOS Sierra.

Build for minimum version of iOS 9.3: Get the 'built for a newer version of iOS than being linked' error.
Build for minimum version of iOS 10: Builds successfully but then gives the error of not finding a valid provisioning profile when trying to install.

Post Reply

Return to “iOS Deployment”