Xcode 7.2 - can't build

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
hutchfx
Posts: 32
Joined: Sat Apr 09, 2011 5:38 am

Xcode 7.2 - can't build

Post by hutchfx » Sun Jan 10, 2016 9:52 pm

I can't build an iOS standalone under Xcode 7.2

I've tried it with LiveCode versions :
7.1
7.1.1 (RC4)
8.0.0-DP-12 | Build 13012

In all cases I get this error:

In order to perform device builds, you must
have the iOS SDK 9.1 or 8.2 or 8.4
configured.
- iOS 9.1 comes with xCode 7.1
- iOS 8.2 comes with Xcode 6.2
- iOS 8.4 comes with xCode 6.4

I thought I had this sorted, and everything was working fine about a month ago... maybe I downloaded Xcode 7.2 in the meanwhile?

Feature Request: It would be very helpful if there was a single place that listed iOS/Xcode/LiveCode versions that play well together. Perhaps a persistent post here on the forum?

Thanks!

Hutch

quailcreek
Posts: 746
Joined: Sun Feb 04, 2007 11:01 pm
Location: McKenna, WA

Re: Xcode 7.2 - can't build

Post by quailcreek » Sun Jan 10, 2016 11:18 pm

I don't believe Xcode 7.2 is supported by LC yet.
Tom
MacBook Pro OS Mojave 10.14

hutchfx
Posts: 32
Joined: Sat Apr 09, 2011 5:38 am

Re: Xcode 7.2 - can't build

Post by hutchfx » Mon Jan 11, 2016 12:50 am

Thank you, Tom, for the reply.

To underscore my "feature request" above...

How are we supposed to know these things? Are there announcements? Is "dig through the forums" the official method?

Thanks!

Hutch

quailcreek
Posts: 746
Joined: Sun Feb 04, 2007 11:01 pm
Location: McKenna, WA

Re: Xcode 7.2 - can't build

Post by quailcreek » Mon Jan 11, 2016 1:35 am

Hi Hutch,
I understand your frustration. There used to be a page on the LC website that listed the LC version to Xcode version but I don't know where it is anymore. They are starting to list the information on the release notes.

http://downloads.livecode.com/livecode/
Tom
MacBook Pro OS Mojave 10.14

dave.kilroy
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 858
Joined: Wed Jun 24, 2009 1:17 pm
Location: Plymouth, UK
Contact:

Re: Xcode 7.2 - can't build

Post by dave.kilroy » Mon Jan 11, 2016 9:37 am

Tom - I think it wisest to have a 'when to upgrade Xcode' approach that is 'upgrade when it is safe' rather than 'when Apple make a new version of Xcode available'

Kind regards

Dave

EDIT: oops, should have addressed this posting to Hutch instead...
"...this is not the code you are looking for..."

peter-b
Posts: 182
Joined: Thu Nov 20, 2014 2:14 pm
Location: LiveCode Ltd.

Re: Xcode 7.2 - can't build

Post by peter-b » Mon Jan 11, 2016 11:07 am

Hi folks,

In LiveCode 8.0.0 developer previews, we are now using a new format of release notes that list the supported versions of Xcode for iOS deployment in the "iOS" part of the "Platforms" section.
LiveCode Open Source Team — @PeterTBBrett — peter.brett@livecode.com

Klaus
Posts: 11197
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: Xcode 7.2 - can't build

Post by Klaus » Mon Jan 11, 2016 1:47 pm

Hi Peter,
peter-b wrote:Hi folks,

In LiveCode 8.0.0 developer previews, we are now using a new format of release notes that list the supported versions of Xcode for iOS deployment in the "iOS" part of the "Platforms" section.
yes, and this is a wonderful thing, but does not help us much when using versions < 8 in the moment.
Is there a webpage that shows us the compatibilty of current STABLE LC and Xcode versions?


Best

Klaus

Thierry
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 648
Joined: Wed Nov 22, 2006 3:42 pm
Location: France
Contact:

Re: Xcode 7.2 - can't build

Post by Thierry » Tue Jan 12, 2016 9:15 am

Here is the official information from LiveCode:

http://forums.livecode.com/phpBB2/viewt ... 49&t=26264

Kind regards,

Thierry
Thierry Douez - https://sunny-tdz.com
Pourquoi tant de notes lorsqu'il suffit de jouer les plus belles... [Barbara]

Klaus
Posts: 11197
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: Xcode 7.2 - can't build

Post by Klaus » Tue Jan 12, 2016 11:01 am

Merci beaucoup, Thierry!

Thierry
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 648
Joined: Wed Nov 22, 2006 3:42 pm
Location: France
Contact:

Re: Xcode 7.2 - can't build

Post by Thierry » Tue Jan 12, 2016 11:19 am

Klaus wrote:Merci beaucoup, Thierry!
Hallo Klaus,

I'll try to keep this post up-to-date.

Anyone can send me a note when it needs to be updated.

Kind regards,

Thierry
Thierry Douez - https://sunny-tdz.com
Pourquoi tant de notes lorsqu'il suffit de jouer les plus belles... [Barbara]

hutchfx
Posts: 32
Joined: Sat Apr 09, 2011 5:38 am

Re: Xcode 7.2 - can't build

Post by hutchfx » Mon Jan 25, 2016 9:14 pm

Thank you!

Fanfanix
Posts: 17
Joined: Fri Nov 29, 2013 3:31 am

Re: Xcode 7.2 - can't build

Post by Fanfanix » Sat Jan 30, 2016 7:34 pm

All,

I am in the same predicament: my LC 7.1.0 fails to build under Xcode 7.2. What can I do in the meantime? How can I go back to my previous Xcode 6.4 ? Do I have to wait until LC works with the new Xcode 7.2? Any suggestions, I would appreciate them.
Thanks,

Drefanix

quailcreek
Posts: 746
Joined: Sun Feb 04, 2007 11:01 pm
Location: McKenna, WA

Re: Xcode 7.2 - can't build

Post by quailcreek » Sat Jan 30, 2016 8:11 pm

You can download previous Xcode versions here.


https://developer.apple.com/downloads/
Tom
MacBook Pro OS Mojave 10.14

msellke
Posts: 22
Joined: Mon Oct 21, 2013 2:57 am

Re: Xcode 7.2 - can't build

Post by msellke » Mon Feb 01, 2016 11:01 pm

One of the main problems with Livecode is that it always lags behind in updates to use the latest versions of Xcode.
Xcode 7.2 was released on the 8th of December and here we are now in February and still no compatible version of livecode for Xcode 7.2 yet.
I love using Livecode but this is one area I believe they need to try & improve on. Other developers have long since released Xcode 7.2 compatible apps yet if you are using livecode you are lagging behind developers using other development platforms.
Sometimes this makes no difference & your apps will still run on the latest versions of iOS & sometimes they won't run at all.

Post Reply

Return to “iOS Deployment”