Provisioning Profile *NOT* recognized

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
tetsuo29
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 63
Joined: Thu Jun 07, 2007 1:30 am

Provisioning Profile *NOT* recognized

Post by tetsuo29 » Mon Aug 17, 2015 10:26 pm

Hi,

I'm trying to compile and test on iOS for the first time. It's not going well.

In order for LC to see my SDK, I've had to grab LC 7.1 RC.

I had been trying LC 7.0.6 & Xcode 6.3 but my phone is upgraded to iOS 8.4 and Xcode 6.3 apparently doesn't work with that.

So, I installed LC 7.1 RC. Now, I can add the SDK from Xcode 6.4. So far so good.

However, none of the instructions on developer.apple.com for creating signing certs, app ids, or provisioning profiles seems to match what I'm seeing. They keep referencing seeing my device in the Organizer window, but all I see in the Xcode Organizer window is two blank tabs- "Archives" & "Crashes".

So, I manually created certs, an app id, and a provisioning profile on the developer website. I've successfully downloaded and added this provisioning profile to my phone in the devices window of Xcode.

However, LC 7.1 RC does not seem to recognize this in the Standalone Application Settings in the iOS section.

I've tried removing and re-adding the SDK in Mobile Support in the LC Preferences.

Still, no profiles in Standalone settings.

Am I missing a step? Did I make a mistake in creating my certs, app id, or provisioning profile? Can I not build for my device and test with the Community edition of LC? (I didn't want to pay for an Indy license without being able to test first.)

For a product that is supposed to make iOS development easy, I feel like the documentation on this subject is all slightly out of date and doesn't give good advice for which versions of LC go with which versions of Xcode/iOS. Makes me wonder if I'd be less frustrated just trying to learn Xcode & Swift. However, I really like coding in LC and I like that it can produce apps for more environments than Mac & iOS.

Thanks in advance for any insights or help.

Pistris
Posts: 146
Joined: Mon Jul 20, 2015 2:40 am

Re: Provisioning Profile *NOT* recognized

Post by Pistris » Tue Aug 18, 2015 9:27 pm

Hi
First of all YES, it is a "complicated process" until you get the hang of it
i my self almost destroyed my mac with a hammer because of the frustration
but thankfully the guys here in the forum walked me through the process

first of all open xcode and remove your apple id under ACCOUNTS
and then add it again, it will download everything again

for some reason (at least on my computer) when i add devices and certificates online and then go to download them on xCode they dont work
it always tells me to revoke and issue new ones
so i delete my account and add it again and everything works fine

then on livecode select the provisioning profile again, even though you will see it the dropdown, open the dropdown and select it again (dont ask me why)

Also forget about the organizer window (you dont have any apps yet), i also lost about a day with the organizer window.

Another thing is you dont need to add the provisioning profiles to your devices, they are added automatically when you install the app in the device.

edd.

tetsuo29
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 63
Joined: Thu Jun 07, 2007 1:30 am

Re: Provisioning Profile *NOT* recognized

Post by tetsuo29 » Tue Aug 18, 2015 9:44 pm

Hi! Thanks for the reply.

I did what you said about removing my Apple ID & re-adding it in Xcode's preferences.

Now, I can add a provisioning profile in LiveCode's standalone application settings. Yay!

But, how do I load the app that it built onto my device?

When I try adding it using devices window in Xcode, I get an error saying that the .app file produced "does not specify a CFBundleExecutable"?

tetsuo29
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 63
Joined: Thu Jun 07, 2007 1:30 am

Re: Provisioning Profile *NOT* recognized

Post by tetsuo29 » Tue Aug 18, 2015 9:51 pm

And, when I try and run it in the simulator (using the test button in LC), I get "Unable to start simulation: Installation Failed"

Pistris
Posts: 146
Joined: Mon Jul 20, 2015 2:40 am

Re: Provisioning Profile *NOT* recognized

Post by Pistris » Wed Aug 19, 2015 6:01 pm

what version of xcode and livecode you have installed right now?

tetsuo29
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 63
Joined: Thu Jun 07, 2007 1:30 am

Re: Provisioning Profile *NOT* recognized

Post by tetsuo29 » Wed Aug 19, 2015 8:24 pm

I'm using LC 7.1 RC 1 and Xcode 6.4.

I also have LC 7.0.6 installed and Xcode 6.3.

I think I figured out the problem though. I changed standalone application name to match the name I set in my app id in my provisioning profile and now I have successfully loaded it on my iPhone. I probably should have set a wildcard app id instead of a specific name.

Thanks for your responses and help. I don't know if I ever would have figured out to remove and re-add my account in Xcode.

Really wish that LiveCode would update their documentation to help people avoid these pitfalls as they begin they iOS deployment journeys.

Pistris
Posts: 146
Joined: Mon Jul 20, 2015 2:40 am

Re: Provisioning Profile *NOT* recognized

Post by Pistris » Thu Aug 20, 2015 7:11 pm

well the actual name does not matter
what matters is internal app id

i actually have a few app with diferent names and using the same profile

the only problem to this is when you install on the phone it will replace the last app even if it has a different name
but on the simulator it keeps all the apps

of course you can create more certificates but am lazy :)

Post Reply

Return to “iOS Deployment”